Brand New Fairphone 2 Won't Turn On

Hi everyone :slight_smile:

I just received a brand new Fairphone 2 as a present.Very exciting, since I firmly believe in the evolution of technology towards regenerative electronics practices. I got the phone 4 days ago, inserted a sim card and plugged it in. It showed a flashing red light and the screen with the picture of a battery charging. The screen-picture then disappeared. Since then I have not been able to get anything out of it. I have tried plugging it into different computers and using different charging cables. I also did a ‘battery reset’ as suggested in the ‘Troubleshooting’ section of the website, and checked the steps of ‘how to get started’ to see if I’ve missed anything out (I haven’t).

As you can imagine, this is quite a frustrating issue. I can understand if technology has problems when you’ve been using it for a while but this machine is brand new!
I tried emailing Fairphone support but I also saw on this forum that some people were waiting for over one month with no reply so I thought I’d try here.

Just to reiterate so that no-one wastes time suggesting things which I cannot do:

–The phone doesn’t turn on at all so if it is a software issue there’s nothing I can do about it
–The sim card works in my other phone so is not faulty
– The ‘on’ button doesn’t do anything, even if I press and hold it.

Any suggestions more than welcome! Thank you :slight_smile:

This might be a contact issue.

I’d suggest to disassemble and reassemble your FP2 as far as it can be done without a screwdriver. In other words, separate display module and core module and put them back together. Also check if the battery sits firmly at the contacts. If this isn’t the case, you might want to simply fill a bit of paper into any gap at the bottom of the battery.

Don’t be afraid, the Fairphone 2 was designed to open. :slight_smile:

More suggestions can be found at Fairphone’s troubleshooting tool:

Not anything means no vibration and no LED light too (even while charging)?

According to our #blackscreenguide that would suggest an issue with the battery/charging. That means either:

  • Your FP2 came with a faulty
  • battery
  • bottom module (USB port)
  • main module (battery pins)
  • all your cables are bad

Oh and did you try plugging it into a wall socket? Computers are not always the most reliable for charging.

Anyway, I’d also suggest - oops urs was faster. I’d also suggest exactly that. :wink:

If it was purchased from Fairphone directly, and was delivered less than 14 days ago, I’d contact support as soon as possible so they can check whether they believe the phone is ‘dead on arrival’ (DOA) (you’ll probably want/need to indicate that the phone is dead on arrival in your message). The DOA exchange procedure should be a better experience than the current parts exchange procedure, if there does turn out to be a hardware issue.


Hi all. Thanks so much for your help! I tried charging it with a wall charger and it worked! Now it seems to be all fine. Thanks again :slight_smile: