Bootloop after Marshmallow Update

I cooled it down and the apps that were being optimized became less and less.
From 104 in the beginning to 80 and now only 48 left.
Lets see if this will work now. :slight_smile:

The period of letting it cool down before trying again is less important than making sure it doesn’t get to hot again during optimizing apps.

The problem is that optimizing apps is a very CPU draining process and if the CPU gets too hot the phone will shut down and it will loop instead of finishing the process.

1 Like

I did the same, 121 to 80, 40, 20, 5. Then finished, reboot, 121 again and again, wtf. It’s so funny, haha.
It isn’t the temperature, the phone updates at the balcony at very cold 4°C here in Berlin.

What a great update desaster.


Exactly the same, I kept the phone 2 whole cycles on the freezer (dry, at -19ºC) and still nothing.
I got the OTA file @paulakreuzer. Is there a way to manually update the phone without a hard reset that would wipe it?


Sure, via #dic:recoverymode.

Is there a possibility to downgrade back to 1.13.0 with manual update? where can i find the i tried with the file from here (, but it didn’t work, cause of signature verification failure…

Well that file is for going back from Open OS, not from Marshmallow.

Try this link:

1 Like

So downgrade is not possible (Can’t install older package over newer build). Hope that factory reset to marshmallow will get me out of the boot loop.

I am having a boot loop too.:frowning:
It’s even impossible on the balcony (3°C) to upgrade it.

Did some of you maybe disable the Google App in Lollipop? That is one very reliable way to end up in a bootloop when upgrading to Marshmallow. I had to learn that the hard way during the beta test…


Yes, I disabled it. Didn’t know I need it.

A post was merged into an existing topic: Can you feel it coming OTA tonight? - THIS UPDATE IS NOT OFFICIAL!


  • Still no successful upgrade, but I wanted to ask if somebody else (that is suffering the bootloops) also gets a red LED on the last ~20 apps being optimized (this seems to have nothing to do with battery charge, since I’ve been getting this with charging cable and without cable but with more than 30% battery right afterwards)
  • Also, as somebody else noted, the amount of apps being optimized varies all the time. It started with 79, stayed like that (optimizing to completion) for maybe 20 loops, then it decreased to 10, increased to 40 and finally increased to 90, where it has been the last couple of loops.

An update to the update:

  • After blood, sweat and tears, I got to manually flash the OTA file via ADB sideload (the sdcard would not be recognized in recovery mode). The process concluded with the “Install from ADB complete.” text but a system reboot brought me back to the bootloop.

Does this mean that, in theory, the image is now correctly installed and the only thing not allowing the phone to startup is the overheating?


I tried exactly the same, but i don’t think it’s the overheating, if you observe the bootloop via
adb logcat *:E
you can see that there are a lot errors concerning app optimization.

I hope that a factory reset will help.

I charged the phone the whole night and the issue persists. Trying to get into the recovery I only get “no command” open-chested andy.

When you see “no command” screen, press again Power and VolumeUp, then leave Volume Up, then Power. Now you can see the recovery menu.

i wondered how i got there last time fiddling around with the combination without paying attention. thanks.
wiping cache…
optimizing 33 apps…done
optimizing 111 apps…if this doesnt work, the os gets the hammer and a full reset. …done.

ok here goes…shit.

1 Like

Will you write if/when you do it? I don’t think I can trust myself to wipe the whole phone and then realising it was for nothing.
I’m trying again after wiping the cache partition

1 Like

cache did nothing. If i remember correctly google introduced a new JIT runtime to marshmallow and this may or may not be the reason the apps could not be optimized.

wiping it helped to get it to launch, though. but everything not backed up is lost.