English

Bootloop after Marshmallow Update

Yeah, I tried that, but then my computer asks which command I want to give, and it gives me this whole long list of options:

'usage: fastboot [ ]

commands:

update
flashall
flash [ ]
flashing lock
flashing unlock

flashing lock_critical
flashing unlock_critical

etc. etc.

It says, when I type ‘fastboot boot twrp-3.1.0-0-fp2-signed.img’:

‘No such file or directory’.

When I type ‘fastboot twrp-3.1.0-0-fp2-signed.img’ (what I accidentally did the first time), then it gives the list of options as I wrote in above message.

Ho, my mistake, I apparently put the file in the wrong folder; slowly making progress here.

Sorry for all the fuzz and questions…

1 Like

Can somebody please test that with a non-Fairphone with Marshmallow? (But please be aware that this phone maybe goes into a boot loop, too, so you should do a backup and know how to reset the phone.) I want to know if that is a Fairphone-specific bug.

1 Like

I got the TWRP working, but even though the data on my phone were in total less than the size of my external SD-card, it gives an error (which is probably related to a full SD-card (although I inserted it being totally empty).

For me, the most important thing, is to get a copy of my pictures and movies (seem to have those, even though the copy of the folder ‘data’ did not fully complete) and a copy of my contacts and messages. The rest I don’t care about.

So, long story short: do you / anyone else know, from which folder I can copy my contacts and messages?

Thanks in advance!

As far as I have seen, the updater did not tell me this.

Now I have the boot loop.

Again, this is a major disappointment and another mess-up in Fairphone communication.

Thanks to you @paulakreuzer, though, I unrooted the phone first.. This prevented me from sweating a lot, I guess.

Now, I know what caused the bootloop : I disabled some google apps (google play games, google play music, youtube). Since when disabling apps caused a system to bootloop ? They are not even system apps !

Now, let’s move on.

If you want to backup your data, please read below !

Go to : https://forum.fairphone.com/t/howto-use-twrp-without-flashing-it-e-g-for-backup/. @retsifp has done another good thing for the community by publishing the TWRP tutorial.

Once your phone has rebooted into fastboot, there are some things to know :

  • When using fastboot, your phone is reachable using adb. You can copy the pictures to the sdcard : cp -R /sdcard/DCIM/* /external_sd/. Please note the ‘*’, which will NOT copy the .thumbnails directory of the /sdcard/DCIM directory. You will spare a few worthless gigabytes.
  • TWRP has a “backup” feature. I don’t know what it’s worth, but since I’ll be doing the long leap to FPOS, I guess this will help. Anyways it’s better than nothing …

I’ll update this post later if I manage to do something. Fingers crossed !

I do not, sorry …

EDIT : I didn’t disable google play, merely google play music & games
EDIT2 : After my first try, it didn’t work, I had to wipe the phone using TWRP in FPOS.

FYI - The instructions given do not seem to work for me. I have tried this (twice - to make sure) and I still end up in a boot loop:

  • Have disabled assist.
  • Have disabled Google App.
  • Still end up with an unusable device.

For my third attempt I supposed I will have to tolerate google’s continued intrusion for the moment.

Does anyone have any further advice?

Thanks.

nitpicking: It’s recovery project, not run project.

4 Likes

hi,
i have miss something… i have reboot the phone to go out the bootloop (and losing all my data)

the operation succes and i have had the possibility to manage the phone (install app, turn off the google apps, …)
but when i have restarted the phone to test, he bootloop again with the same message “Fairphone Change is in your hands” and with several optimization of my apps.

what else can i do more ? (not touch the google apps ?)

thanks

Please read the second post which is marked as the solution of this thread.

1 Like

Ok, Thanks, it’s all good :slight_smile:

I think they are, as usually GMS are system apps (though I can’t check as I don’t have them installed)
Anyhow, I wouldn’t be surprised if Google simply does not allow to deactivate their apps.

I confirm Youtube is indeed installed in /system/app. I don’t remember about the others.

What I meant was that Youtube, although installed in /system/app, is not per se an app that requires system privileges …

Plus, I disabled the applications using the application list, and not using the usual shell script I use after each update when my phone is rooted.

Nothing prevented me from disabling those apps neither …

Anyways, now that I made my leap of faith to FPOS, I’m eager to get Marshmallow :slight_smile:

Hello everyone,
I am stuck in the bootloop as well because I turned off the google app.
Now I tried to hard reset my phone. I get to the ‘resting’ android but pressing the power button (or any other botton) does not open the menu.
Thank you for your help in advance

Recovery changed a bit.

You have to:

1 Like

Ah, I jumped to the extended Guide and didn’t see the new quote. Thank you very mutch!

Hi there. Thank you for all the great comments!

Did anyone manage to restore their backups and/or copied data + apps?

I ended up in bootloop but managed to do a backup with twrp in fastboot after that. I also copied all the data on the internal storage.
However, every time I put the backup on the phone I end up in bootloop again. Has anyone got an idea for an easy way to get my data and apps back on the phone without manually reinstalling everything or ending up in bootloop?
Any suggestions much appreciated!

Hello! I am having Problems with my fairphone 2 after the upgrade as well. It basically seems to have broken my phone completely. There’s three aspects of the Problem and only one is the bootloop but I cannot solve it the way it’s described here. 1st: when it upgraded, at some Point it just completely froze without finishing. After nearly a day it still had not finished and the Screen was completely frozen. It could not be turned off either. I had to remove the battery for it to turn off. Problem was after that the phone was pretty much dead. I cannot turn it on at all when the battery is inserted, even when it’s hooked to a charger. I have to remove the battery for it to actually do anything at all. When I do and I try to turn it on, it starts up for a few secs to the fairphone Screen and then turns off again and then starts up again, repeating this endlessly. I cannot Access recovery mode. Pressing the Buttons does nothing. Can the update or me taking the battery out have damaged my phone or the battery on a Hardware Basis? And do you have any idea what I could try to get this Thing up and running again? I don’t really care that much about the data. It wasn’t much to begin with. Any help would be appreciated. =(

You can try to flash the binary images manually (method 4). This does not require recovery mode.

(BTW, the easiest way to get fastboot is to download the Android SDK Platform Tools. It’s a small package and doesn’t require installation.)

I killed youtube the moment the UI became available to me, what with the recent permission requirements.
I still haven’t found the location of the assisst setting, however.