Bootloop after e/os/ update

Hi everyone !
I’ve got a FP3, order directly with e/os/ installed on it. I never updated it, and since I had small phone reception problems lately, I decided to update e/os/. I went to the update menu on the phone, selected the most recent update, and then, when it rebooted, the phone is stuck in a bootloop unable to boot. Even in recovery mode. It always display the message “Can’t load android system…” with the two options of trying again, or data reset.
And now, i’m wondering what are my options ? Of course I don’t have a recent backup, else I would have just data reset everything.

Is their any way for me to do something or should I just factory reset everything ?

Welcome to our community forum :slight_smile:

I think the deciding question is: Is your bootloader locked or unlocked right now? (booting into Fast Boot Mode will tell you) If it’s locked, I can’t see an option to avoid the loss of data (i.e. factory reset).

Hey ! Thansk for the quick answer : )
I boot in Fast boot mode, and It says at the bottom «Device state locked». Is it that that means that bootloader is locked ?

Secure boot is disabled

Yes, unfortunately. The final line indicates the bootloader state.

I assume this means you cannot allow ADB in recovery mode, right? (in Recovery Mode: Advanced > Enable ADB )

I managed to enter ADB Sideload (is that what your refering to ?) and tried to access it via adb from terminal. I can see the device listed, but when trying something like “adb shell” or “adb usb”, it keeps telling me “error:closed”

also tried “adb backup -all”, but it says “adb: unable to connect for backup: closed”

I suppose all these error messages are created because your bootloader is locked (and so all these adb commands are not available/allowed).