Bootloader stays locked

Hello everyone,
Im trying to get calyxOS or /e/OS on my fairphone 4 but whatever I try, my bootloader wont switch to ‘unlocked’. I tried to ADB it, but i cant use ./fastboot for some unknown reason. I am using a mac, and also tried installing it by using the /e/OS easy installer but that also gave an error at ‘can not get the security patch level’.
OEM is unlocked, ADB debugging is on. Only fastboot stays on ‘unlocked’ in my bootloader.
Thanks in advance!


is the opposite of

isn’t it? So what’s the status then?

What means “can’t use” here? Does using “fastboot” give you an error?
There have been reports on the forum about adb working and fastboot not working and I think sometimes it helped to use different USB cables or USB ports…

Maybe you have another computer (linux, windows) too, to try it out with that?


Hi! Thanks for helping out!
Im sorry, its a mistake: fastboot stays ‘locked’ instead of ‘unlocked’.

1 Like

Yes! I read that i could switch computer or cable. I have definately tried different cables and usb-c ports, but that did not help. Also i tried using parallels desktop since i only own a mac computer, but sadly that did not work either.

1 Like

You haven’t answered my question regarding the error when using fastboot.
So what happens when you have your usb connected FP4 in bootloader and execute fastboot devices?
Don’t know about Mac, but in Linux it can also help to use sudo fastboot devices.

1 Like

Hi Volker!
I must have overlooked that one.

When I type “cd ” , then '“./fastboot” It already gives me “fastboot: usage: no command”. If i do “./adb” it starts running adb. When I type “fastboot devices” it says: “zsh: command not found: fastboot”. when i do “./fastboot devices” it gives me the location of platform tools with "% ".

About the sudo:
When I type ‘sudo fastboot devices’ it says “zsh: no such file or directory: ./sudo”
Now I tried with first typing “sudo cd ” and then using sudo adb it says command not found. When I type “sudo adb fastboot reboot bootloader” It says “zsh: no such file or directory: ./sudo”.

What can I do?

I’m not exactly sure about this output. Normally it should show an ID of your FP4.
Still it sounds like ./fastboot flashing unlock should be the correct command for unlocking your FP4 while it’s connected via USB to your Mac and while it’s in dic:fastboot mode.

1 Like

Hm, thats what i thought, but it still won’t work. Now i start wondering if i am doing something wrong with running ./fastboot on my mac. It seems like that is the first step that does not work.

1 Like

Are you on an ARM Mac by any chance? :thinking:

There are apparently issues with fastboot on M1/2 systems. CalyxOS for example doesn’t currently support flashing from one of those because of that.


Oh yes! It might help already to try it on any older mac of someone i now. I will be able to try that in two weeks. Ill keep you posted! Thanks!

Just my two cents, if you have trouble with running Fastboot on MacOS, on the same computer you can start Linux from an USB-pendrive…


3 posts were merged into an existing topic: Howto install Calyx OS on FP4
as trying to unlock the phone with an usbc to usb adapter (and the fairphone cable then from usb to usbc) worked and there’s now a problem to install CalyxOS.

Thank you all so much! I just finished, and it is working perfectly! Only my (triodos) bank app is not working well… Hope I can find a solution soon.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.