Bluetooth music interruptions


When I connect the FP2 to my car to listen to music (using PowerAmp app), it is not smooth at all. Every 2 seconds I got an interruption of a half second. It’s as if the flow was kinda limited. Really awful.

I tried with an other android device (MiPad) with the same app, and everything goes very well. So the problem comes from the FP2, but how to fix it ?

Thanks for help

Have you installed the latest update of Fairphone OS? That problem is known in older Fairphone OS versions, but was fixed with an update.

If the updater doesn’t find the update, you have to install the latest version of “Fairphone Updater” from the Google Play Store.

1 Like

I was on open OS 17.07. Now I changed to Lineage OS 14.1 (Android 7.1.2) but still no change. It’s impossible to listen to music via bluetooth. Always cutted every second.

I have the same issue, for almost two years now, with my FP2. The update that should have removed the issue reduced it but since then it seems to have increased again. My FP2 is on standard FP OS and I have always directly updated the OS. The interruptions are not regular, sometimes more, sometimes less. But enough to spoil my music.

Had the same back around may 2016 but it was quickly fixed with a firmware update.

Have you tried with a different application or a different Bluetooth headset?

Have you tried to put all other radios off? Especially other radios at 2.4 GHz (such as WiFi) can cause interference.

Thanks for the reply.
Yes, with a different headset or bluetooth speaker the problem seems not to appear… but it is my carkit (Toyota Prius plugin) that is giving the trouble. And I am certainly not going to buy another car for this reason!
I have tried switching off Wifi on the phone. It seems to help a bit but not fully. Also, I would then need to switch wifi on/off every time I jumped into my car?
I have several times disconnected the pairing and paired the phone and the car again, no relief.
As I said, that 2016 update seemed to help but afterwards (later updates?) the problem returned.
There are more issues:

  • Pairing with my car is often difficult, more so than it was with the first versions of phone software
  • After starting the car, bluetooth playback doesn’t resume automatically (with my previous phone (and early on with the FP2 it did)
  • My steering wheel buttons no longer work for previous/next track (they have before)
    I have looked for updates of my car but didn’t get that to work after several hours of trying.
    So, if it is the FP2, the Prius or whatever: I cannot use my FP2 for one of the uses I bought it for.
    Any other Prius owners with FP2 (the groups should overlap :slight_smile:) , does it work for you?

Have you checked for firmware update for the carkit?

Yep, I recommend to put WiFi off when you’re not at home. It works against tracking (alternative is WiFi Privacy Police), saves your battery, and you can always enable it if you’re within the vicinity of an AP while on the move.

You can also swap back to an older FP2 firmware to pinpoint where exactly the problem started to occur.

Do you know any other WiFi or Bluetooth radios which are enabled? A HRM, headset, laptop, tablet, watch, OBD2 device, etc? Or anything else on 2,4 GHz? You can find out interference with specific software. Examples: WiFi Analyser and BlueBorne Vulnerability Scanner by Armis.

[quote=“BvdRee, post:6, topic:32754”]
My steering wheel buttons no longer work for previous/next track
[/quote]Yeah, I had same with my smartwatch. You need to give the application access to control the device.

Thanks. Have tried updating my car for several hours but after about 5 hours I quit. Extremely confusing. Will try Wifi Privacy Police app, thanks! May take a little time.
I had one of the first FP2s so I have had all updates from the first one, none really worked.
Last time I paired my phone, it asked about TUN protocol, I allowed that. Should that have taken care of the buttons? On one screen, the car mentioned about a dozen bluetooth protocols it had, I didn’t even know those existed… is there documentation on which protocols FP2 supports?
Anyway: I follow your thought that it might be in the car, more than in the pone. Not that documentation on Prius is any better…

Could you tell us more about the firmware on your car? What version are you running? Then we can work out about the features or bugs it may or may not have.

WiFi Privacy Police is a nice app but shouldn’t solve your problem (except maybe if you use the whitelist feature). It is just an aid against tracking.

I’m not sure how tun protocol could be related to your use case.

According to Wikipedia the Fairphone 2 supports Bluetooth 4.0 LE (that’s both non LE and LE). LE is meant for very small embedded devices such as HRM, smartwatches, … I can verify it works with BT LE, but I doubt you’re using LE in your car.

I suspect there’s something wrong with the signal. If I were you, I’d try to verify with a phone of a family member or friend and see if that does work. If you tried out those 2 apps to see which other devices are broadcasting at 2,4 GHz then perhaps something is blocking the signal in some other way ie. physical.

We’re talking very likely about A2DP. One alternative in your situation could also be to use a A2DP -> 3.5mm adapter. I just looked for some and saw they’re only 10-20 USD (which one’s good I don’t know). I’m of course not sure if your car has 3.5mm input, to receive the Bluetooth signal from the FP2 but you could also try to plug in the adapter in your FP2 as output on the 3.5mm and that I am pretty sure should work. You disable BT and WiFi on the phone (so that they don’t interfere). If it works, try with enabling both, see if that works.

BTW you might also wanna disable WiFi and BT scanning in Settings -> Scanning. Android periodically searches for WiFi and BT addresses for tracking^H^H^H^H^H^H^H^Hscanning. By default it is done in addition to GPS. Happens even if they’re disabled (hence also WiFi Privacy Police but you’d need to use the whitelist).

Thanks again. Will check my carkit version, but it may take a while as I have a busy week ahead of me.

Your experience resembles mine with my Dacia MediaNav Carkit.
My FP2 seems generally very stable and only reboots from time to time when I connect it to the car thing via Bluetooth to play music or listen to Google Maps directions.
It never happened during a phone conversation, but I only had FP2 for a few days, I’ll keep track of what happens next.

Sorry it took a while, but here are data about my car. It says: Navigation: VA05113A, Bluetooth 21.210. On another screen ‘detailed bluetooth settings’ it says ‘Profiles: HFP DUN OPP PBAP A2DP AVRCP MAP’. I see nothing about Bluetooth 4.0 LE. I can’t find other screens with firmware versions (are they there?).

A2DP is mentioned so it should be working, I suppose.

I would rather not buy a 3,5 mm Bluetooth adapter, because then I suppose I would also lose operation of my phone from my car, f.i. if somebody calls me, I can answer using buttons on my steering wheel.

Does this give you any thoughts?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.