Bluetooth audio bug on Android 12

I use headphones and a speaker (Vifa) that both use AptxHD and I bought these specifically for the sound quality. I have managed to stop the daily update notification that appears in the notification area. I am still however getting a screen within the main screen (ie: a Big rectangular message box that pops up) daily notification that there is an OS update and inviting me to download and install. I am NOT prepared to install ANY OS update AT ALL until the bluetooth bug is fixed. Can someone please tell me how I stop that OS update notification? Thank you everyone.

Thanks that you take the problem seriously! Tho I’m really disappointed at the moment, cause I just bought new headphones for the better listening experience, but I’ll be patient :raised_hands:

I hope the fix is almost ready ^^

I have to go into Dev settings every few days and turn it onto AAC and then my Sennys work, but it doesn’t stick. But it’s good to see this is getting fixed.

In the meantime you could try to switch the codec automagically

1 Like

Another workaround is to turn of HD-audio in the Bluetooth menu. Then you don’t need to go to developer settings all the time. It sets Bluetooth to SBC instead of AAC but the difference isn’t that noticeable on Android.

A fix for this bug is included in the latest software update.
If you previously disabled HD Audio, remember to enable it after updating.


I can confirm that HD audio is working with FPOS B.048


Unfortunately it doesn’t work for me. Tried it with my beyerdynamic headphones and my Cambridge DAC.
Every time I switch to aptx my Deezer App stops playing.

1 Like

Not on my FP4. I just posted the details on the software update thread

1 Like

Unfortunately the posts after mine are correct, after a reboot and a second try the aptx problem is not solved on my phone either. Actually, I do not know why it seemed to work when I tried it in the first place.

I just got new earbuds, and found that, though they connected by Bluetooth, no sound was played. I eventually discovered that this was because they were using the aptx hd codec. I noticed that this bug was supposed to be fixed in the latest update, but unfortunately it turned out not to have been, for my phone at least.

Hi and welcome. Assuming you have a FP4 with todays update, I moved your post to this topic.

1 Like

Yes, it was encouraging to see that the very problem that I had noticed was supposed to be fixed with this update, and very disappointing to find that it made no difference at all.

1 Like

AptX Adaptive still not working on my FP4 with this latest update . Same symptoms as before when HD audio is enabled. BT device is iFi Audio Go blu. It worked correctly with Android 11 and works correctly with my old OnePlus 6 (Lineage 20 & LDAC). Very frustrating. LDAC on the FP4 works as it should when changed in developer options

Hi there!

Unfortunatley aptx still doesnt work. No Sound on my Beoplay E8. When i Turn Off HD Audio they Work. But the Sound ist horrible.



About aptX: unfortunately aptX does not work for me.

I have a Pioneer SE-MS7BT which can be used with aptX on other devices without any issues. I also tried to remove an re-pair it - no luck. The same behaviour as before: with aptX enabled I only hear a faint constant ticking sound with about two ticks every second as soon I start audio playback. As soon as I disable aptX the headset works fine.

Hi, I’ve done some troubleshooting and can probably explain why some users are reporting the bug as fixed, while others still have issues.

  • The FP4.SP21.B.048.20230215 update does indeed fix aptX HD.
  • It does NOT fix aptX or aptX Adaptive.
  • LDAC works but does NOT get automatically used, see workarounds 2 and 3 below.
  • Bluetooth devices that support aptX or aptX Adaptive will automatically use these over AAC or aptX HD because the FP4 lists these broken ones as higher priority in the bluetooth audio codec list.

Current state of codecs, as of update FP4.SP21.B.048.20230215:

Confirmed working by me:

Confirmed BROKEN by me:
aptX, aptX Adaptive

Confirmed working before the bug was introduced:
SBC, AAC, aptX, aptX HD, aptX Adaptive, LDAC.

If your bluetooth device still can’t play sound with the FP4.SP21.B.048.20230215 update there are 3 workarounds you can try.

Workaround 1:
Free, Automatic each time it connects, Safe

Simply disable “HD audio” like this:

  1. Go to “Settings > Connected Devices”
  2. Click the Gear-icon ( :gear:) next to your device.
  3. Untick “HD audio”.
  4. You should now have working bluetooth audio.

The drawback of this is that you’ll be stuck with SBC (the lowest quality bluetooth codec) until the bug is fixed and you can re-enable “HD audio”.
If you want an option that retains “HD audio” quality with a working codec see Workaround 2.

Workaround 2:
Freemium, Manual switching each time is Free, Automatic switching each time Costs $3.13 USD or €3.49 Euro, Safe

The app “Bluetooth Codec Changer” on the Google Play Store can make the process of switching codec quick and painless, or even automatic if you pay for Premium in the app.

You can get the app here:

You can manually change codec in the app, setup a widget on the home screen, or use the notification to trigger a switch.

If you buy Premium you can setup automatic switching following these steps:

  1. Connect your bluetooth device and confirm it shows up in “Bluetooth Codec Changer”.
  2. Go to “Bluetooth Codec Changer” Settings.
  3. Turn on “Auto Switch”.
  4. Turn on “Background Service”.
  5. Click “Default Codec” and select your desired working codec for this bluetooth device.
  6. Notice that you now have an entry with your selection for this device under “Device Control” which you can delete if you need to remove it or redo it.
  7. You may want to change “Execution Delay” if it doesn’t work reliably, I suggest raising it by 1 second each time until you find a delay that works.
  8. You should now have automatic bluetooth codec switching to whichever codec works best for you, probably aptX HD, LDAC, or AAC, depending on your device.

Don’t forget to remove the devices from “Device Control” in the app once this bug is properly fixed. If you want you can also remove the app once the bug is fixed.

Workaround 3:
Free, Manual each time it connects, Potentially dangerous

You can manually switch the bluetooth codec of your device by using the hidden “Developer options” menu.

To access the “Developer options” menu and do this follow these steps:

  1. Connect your bluetooth device.
  2. Go to “Settings > About phone”.
  3. Scroll down to “Build number” at the bottom and press “Build number” 7 times in a row.
  4. Enter your Pin/Password/Authentication if asked.
  5. You now have “Developer options” available if you go to to “Settings > System > Developer options”.
  6. In “Developer options” search/scroll to “Bluetooth audio codec” and select your desired codec, likely aptX HD, LDAC, or AAC.
  7. You should now have some kind of working “HD audio”.
  8. Repeat this from step 5 EVERY TIME you connect your device again, this setting is NOT remembered between bluetooth uses.

Once the bug is fixed you probably want to go to “Settings > System > Developer options” again and Untick “Use developer options” to re-hide this menu.

Which Bluetooth audio codec is the best? Which should I use?
For reference here is a link with a list of all current Bluetooth audio codecs and their technical performance:

If you want my opinion I would rank the FP4 supported options like this, from “best” to “worst”. My ranking is purely based on sound quality and I don’t care about “latency” which might be important for gaming for example:

LDAC, aptX HD, aptX Adaptive, aptX, AAC, SBC.


Unfortunately the fix does not work for me either. I have Pioneer SE-MJ771BT headphones, that worked fine with android 11.

Just installed the update, but AptX audio is still not working on Sennheiser Momentum 4 headphones. Hope this can be fixed very soon!

Updated yesterday evening but at first testing aptX still does not work (Cambridge Audio earbuds)