Bluetooth audio bug on Android 12

I seem to have a problem with Bluetooth audio after updating to Android 12. It simply doesn’t play. Is anyone experiencing the same problem? I have tried to clear Bluetooth cache, unpair and restart, but that doesn’t help.


I’m having the same problem. Turning off aptX in the settings of the Bluetooth device you’re using fixed the problem for me. Tried with 2 different Bluetooth devices, both had the same issue


AptX isn’t even supported by the Fairphone, it’s strange it’s even listed there.


Aptx and Aptx HD worked perfectly on Android 11🤔


Wait how is it not supported? I was using it on android 11 and as far as I understand it’s a feature of the chipset, not the os.


My bluetooth headsets works: Bose OE SoundLink with HD-Audio: AAC activated.

AAC still works, but AptX and Aptx HD doesn’t.


It’s not in the spec sheet and FP support told me that for AptX you need an extra license or something, FP didn’t get it. I suppose it falls back to AAC or it was a software bug in Android 11. But in any case FP doesn’t have AptX.

1 Like

Good to know. Although I hope fp changes the default behavior in that case. Every bt device I have has aptx on by default (in the settings menu for that specific device). Having to turn that off isn’t a deal breaker to me, but it might be to someone that isn’t tech savy and is wondering why their bt headphones don’t work.


I’m having the same issue.

I installed a firmware update on the headphones but it hasn’t made a difference.

I notice that others have had issues with Sennheiser headphones with FP3 though my FP was working perfectly with mine until before the update.

So I tried a different pair of headphones (JBL) and they work okay…it must be some compatibility issue with Sennheiser.
Not sure if there is a fix though?

Hi, I have the same “problem” here with a pair of Sennheiser Momentum 2. Only SBC works… annoying…

1 Like

Did you try the above mentioned workaround/solution?

I am afraid that there is no workaround. I also tried different settings (+dev settings), repair, …

So this is another bug and not this one?

Have you reset the Sennheiser BT device and tried newly connect?

I connected my headphones (Sennheiser HD350BT) this morning, and they would not play.

So i disabled, as suggested, AptX and they started playing again. Out of curiosity i opened the developer options to see which Codec they use, to see that disabling AptX in the “Bluetooth Device Settings” completely disabled HD-Audio.

Since there are other HD-Codecs which are supported like high bitrate SBC and AAC, this will lead to those enabling the workaround with worse audio quality.

Having manually enabled HD-Audio again, and selecting AAC everything works as expected :slight_smile:

Edit: Oh no, seems this is no viable workaround either. Having restarted my Fairphone, enabling HD-Audio in the developer Settings seems to enable all HD-Codecs with AptX being the “default” one. Either i manually chose AAC / SBC in the developer options on every connect/reboot or i disable all HD-Audio Codecs.

1 Like

Same happening to me since updating to android 12.
My handset spec states aptx compatibility but the headphones are mute.

Changing the codec in developer option to AAC works, but at every coupling the preferenze Is Lost.
Disabling Audio hd: audio Qualcomm aptx in the pairing settings works, but feels like going back.

Waiting for a fix from fairphone!


this is my first Post :slight_smile: . I have the same issue and this made me very sad.
I use the Soundcore Liberty 2 Pro Earbuds and i love to hear music. The Qualcomm aptx HD Audio Codec doesnt run under Android 12 :frowning: under Android 11 all works fine I hope Fairphone fix the Bug!

The post has now been marked as “solved”, which is not the case at all. It would be nice if there was feedback on this.


Hi everyone,

Thank you for flagging this. Our software team is aware of the issue, and are in the process of validating a fix. I can’t confirm if it will be ready for the next release but I’ll keep you posted.

In the meantime, disabling HD Audio in the Developer options is a viable temporary workaround.

Apologies for the inconvenience.