Bluetooth audio bug on Android 12

I see a few people claim that the aptX HD codec still doesn’t work for them.

I would like to know how you’re testing this if you are affected. Either its true that aptX HD codec is still broken for some users, or they are perhaps confusing aptX HD with androids “HD audio” name, or another version of the codec such as regular aptX or aptX Adaptive.

FP4 appears to prioritize the bluetooth audio codecs like this, from 1 being highest priority to 6 being lowest:

  1. aptX Adaptive (Broken)
  2. aptX HD (Working)
  3. aptX (Broken)
  4. AAC (Working)
  5. SBC (Working)
  6. LDAC? (Working. Does not seem to get used automatically?)

If your bluetooth device supports aptX Adaptive it won’t fall back to aptX HD even if aptX Adaptive is broken. If your device supports up to aptX it also won’t fall back to AAC even when aptX is broken. If your device only supports aptX HD as its highest level it should now work out of the box with the latest update. If your device only supports up to AAC or SBC it’ll work out of the box.

See my post here for some workarounds to get working “HD audio” even if your device won’t automatically fall back to a working codec by itself.

I hope this clears up any confusion for users. Of course this bug is not fully resolved until aptX and aptX Adaptive also works correctly. I am fully expecting Fairphone to fix this bug for all available codecs, anything else would be disappointing.

For reference during my troubleshooting I used a number of different bluetooth devices to test. I used both the hidden “Developer options” menu and the Bluetooth Codec Changer app to switch between the available codecs for each device to confirm which ones were working and which ones were broken.

Here are my findings in full:
All testing done with the FP4.SP21.B.048.20230215 update.

Fairphone True Wireless Earbuds
Available Codecs: SBC, AAC
Working: SBC, AAC

Sennheiser Momentum True Wireless 2
Available Codecs: SBC, AAC, aptX
Working: SBC, AAC
Broken: aptX

Bang&Olufsen Beoplay Portal PC/PS
Available Codecs: SBC, AAC, aptX HD, aptX Adaptive
Working: SBC, AAC, aptX HD
Broken: aptX Adaptive

Topping DX3 Pro+
Available Codecs: SBC, AAC, aptX, aptX HD, aptX Adaptive, LDAC
Working: SBC, AAC, aptX HD, LDAC
Broken: aptX, aptX Adaptive
Note: LDAC should’ve been used automatically as the highest quality option, but aptX Adaptive has higher priority in the system and thus necessitates extra steps for switching to LDAC. This should in my opinion either be adjusted or make it simpler to switch to LDAC as the default for devices that support it.

Additional observations
As noted by @RAD above in this post there is sometimes a faint “clicking noise” or perhaps “ticking” when selecting either aptX or aptX Adaptive for me on some devices. Perhaps this is some kind of artifact of the connection attempting to reestablish itself constantly or something. I’ll leave this to the developers to investigate.


Sorry, it seems really only HD audio does not work, but what else worked under Android 11.

Here is an example::

1 Like

Jabra Elite 3
Available Codecs: sbc, Qualcomm aptX-Audio (nb: Qualcomm aptX-HD ist NOT available)
Working: sbc
Broken: Qualcomm aptX-Audio
And yes: there ist the below mentioned “faint clicking noise” when selecting aptX-Audio
Regards. and thanks to everyone trying to get these issues ahead. I feel so stupid having given a chance to FP4 after a frustrating single year with FP2 - the least sustainable Cell Phone I have had so far.

1 Like

Not having a device with AptX just reading above detailed explanation and seeing your screen, your device offers Aptx and not AptxHD and therefore for you HD Audio is broken


The Bluetooth option from the headphone called HD-Audio: Qualcomm aptx-Audio. nobody cares which codec is behind it. And nobody has to understand that they ONLY fixed aptx HD.
Fix the Bug!

1 Like

Hi you do realise this is just a user forum, so such demands/commands are inappropriate.

Further: Fairphone do monitor the topics they create and so it is better to add your comment to the their last topic which is the System Update.


Wrong, my devices offer it, I just had to turn it off so that I can listen to music again.
I just wanted to point out the “HD Audio”.


1 Like

Same here. With KOSS Porta Pro Wireless

working bluetooth codecs : SBC, AAC ,aptX HD ,LDAC
not working : aptX

tested with FP4 on Nuber A-125 and Sony WH-1000XM2


Again to anyone here:

From previous posts I installed:

Bluetooth Codec Changer.

It works quite well to quickly switch the CoDec.

You will easily find out what your device is offering.

What is working:
SBC (seen as SD in Bluetooth selection by Android, so what is used when toggle “HD” is off)
AAC (Already the first CoDec seen as “HD” even if this is wrong)
APTX-HD (that is the older high quality one}
What is not working
APTX adapted (that is the newer high quality one)
What is unknown


I have the same problem with my music apps, they freeze on my Fairphone 4. I can’t use my IFI GoBlu with aptX Adaptive. It works if I turn it off but that cancels my interest in using the GoBlu. Thankfully the phone connection in my car still works over Bluetooth. I don’t know if aptX HD is available on my phone as I can turn aptX Adaptive on and off but that is the only version of the codec I can see.

1 Like

Hi and welcome to the community, I moved your post, please read above foe further workarounds while waiting for a final fix

1 Like

The reason I posted were I did is because the creator of the thread wants feedback on the latest software update. This thread is has no solution for my problem. I’m reposting in the original thread hoping my feedback will be left there.

The poster also posted here and we keep for specific wide spread issues own topics and therefore move posts as needed.


Hi @yvmuell ,

i hope it comes a new fix. Did a fairphone employee give feedback that it will be fixed at all?

Hi, thanks for starting the thread with update issues.
I don’t know if it is related but since I installed the update, I cannot connect any more to my headphones via Bluetooth. This worked without problems before. Now, the headphone shows that I am connected, the FP4 shows that I am connected, but the sound remains with the device, and the headphones remain deaf & dumb.
My Fairphone’s build number is FP4.SP21.B048.20230215, too…do they all have the same number?

Thanks a lot for everyone who knows what to do - I need my headphones all the time for video conferences, and MS Teams/ Webex don’t work well with Linux but, until the update, they DID work with my phone.

1 Like

I moved your post here pleaeßse read above

1 Like

I have the same headphones (Sennheiser HD350BT) and turned off aptx qualcomm/HD audio and it worked. Haven’t tried anything else since then. Just for information in case it’s relevant.

I had the same issue since the 13th of Feb update, with “MOMENTUM On-Ear 2 - Sennheiser” headphone and Managed to solve it with workaround 1 above. Many thanks !!

Using libratone track+, fp4, latest Android 12 update.
All Bluetooth working fine both AAC and SBC.
BUT: whatever I do I don’t get Ms teams app to work with the headset anymore.
I know the Ms troubleshooting for that, using both cache delete and reset of bt connection.
Still no headset on fp4, company profile and bt device.
Anyone seen this behavior?
I completely depend on teams and need to work hands off the phone.