Bluescreen after installing ubuntu, phone does not recover

Dear, fair, fp-community,

since ubports-installer did not work for me (nothing happened for hours besides the gui’s loading-loop) I tried to install via the magic-device-tool. After several tries (there were first issues with the recovery mode), I got my fairphone2 so far that everything seamed to have worked except for the fact that during the normal start (not the booting or the recovery) I had a blue screen (the first time, I have had some sound and also some darker stripes, later it only went blue).

So I tried to fastboot a twrp recovery which did not work either.
this is what it said:

elina@elina-ThinkPad-Edge-E531 ~ $ sudo fastboot flash recovery twrp.img
error: cannot load ‘twrp.img’

I found in a forum the issue, that android 6.? is not suited yet for “ubuntu 16.4 stable” but “16.4 devel” helped some users with the bluescreen issue. But since I cannot work with wbports (and I really don’t know why, tried that on my osx and my linux pc) and magic-device-tool did not give me the option to choose between a developer and a stable version, I feel I am getting out of options. Is there any possibility to just get back to simple android? or to run my fairphone2 with lineageOS? In the ubports’ recovery mode there is no option to recover. I got that phone yesterday and now it seams that I have bricked it. Are there any ideas what there is left to try?

I am not that experienced in programming, so if you advise me, I might need to be led step by step…

you can also answer in German or Dutch if this is more comfortable for you

Thank you in advance :sunny:

Into which path did you download the TWRP image, and is the filename really “twrp.img” (it isn’t named that way if you download from

Else … you can boot a signed TWRP image without flashing it …

1 Like

The error means you executed the command inside a folder that doesn’t contain the downloaded file and/or didn’t use the correct name of the downloaded file.

Assuming you downloaded the newest version of the file into a folder called “Download”, this is the correct command

sudo fastboot flash recovery ~/Download/twrp-3.2.3-0-FP2.img

1 Like

Did you try version 1.12 or 1.9 of the ubports-installer? If the latest version doesn’t work, those might…

Magic-device-tool is not updated anymore for UT. Seems to me that it installed an old 15.04 version that was before the bluescreen fix for the new camera…

Hi everyone,

first of all: thanks for all your replies.
I finally found a way to re-install Fairphone OS, also Fairphone Open OS is working on my FP2 (except for Wifi, but at the moment this is nothing that concerns me).
On this way it was possible for me to install TWRS, thanks to your link @AnotherElk

@Ingo actually I renamed the downloaded file for convenience reasons. But during the whole day yesterday, fastboot and adb did not work properly with my Mac or Linux PC. And still I did not make it work yet. Actually I hoped to find a work around it via installing TWRS without any PC, but since it worked with the signed version so fine, it is perfect for me :slight_smile:

@oli.sax: since I have this information, maybe I’ll try my ubuntu installation next weekend

So since TWRS was working and after a few trial and errors I was able to install LineageOS in TWRS and it is working very well finally!
(another topic: Maybe it is necessary to know that the zipped files, that my Mac unsolicitedly decompressed after the download could not be used in the process of installation via TWRS, but after downloading them in linux, they did their job smoothly)!
Have a fine weekend everyone!

1 Like

If you still want to install Ubuntu Touch, TWRP probably isn’t of much help, because UT require their own recovery system.

The graphical installer is a little tricky. I got it working with 0.1.21 a couple of times but it is somewhat shaky. If that doesn’t work, 0.1.12 and 0.1.9 are the versions where others reported success.

If you are willing to test, I’m trying someone else’s fix for the infamous “booting…FAILED (remote: bootimage: incomplete or not signed)” error. But unfortunately the installer has some more problems depending on the platform and type of binary used. And also at the moment I only manage to create the DEB and AppImage packages. But they seem to have another bug when it comes to running some of the commands as administrator after entering the password.
Edit: the latter problem only occurs when one doesn’t use the android-tools provided by the distribution (those are usually placed in /usr/bin; other locations are unlikely to work due to the configuration of sudo - which doesn’t even include /usr/local/bin on opensuse).

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.