BlackPlayer and Fairphone

Anyone tried to install the BlackPlayer on FP1? It doesn’t seem to play any sound, neither over headphones nor over speaker. Please reply to this if you have similar issues. I also wrote the developers and will post their answers here if there are others with this problem.



I just gave it a shot - I installed this BlackPlayer (not sure whether there are similarly named apps), but for me audio is playing normally, at least over headphones (I’m currently not in a suitable environment for a speaker test) and from flac files.

Huh. Yeah, that’s the app I mean. I assume you have the most up-to-date Kola Nut 1.8.7. installed? I can run the “Music” app just fine, and all other sounds. BlackPlayer remains silent… strange.

Yep, FP1 first batch, Kola Nut 1.8.7 + storage layout update, settings for BlackPlayer as they were out-of-the-box.
Sometimes these issues turn out to be specific combinations of player + audio format. I can try some other formats later (I need to look for files or recode some my tracks). Any specific type you’re trying to play?

But you don’t have any error message?
The song is displayed as “playing”?
You don’t use XPrivacy which could block any permission the app need to play the sound?

I’m trying to play mp3 files. Nothing special about them, and I’ve tried them from different sources (not just my own). I don’t get any error messages, the tracks display as playing in BlackPlayer. I also enabled and disabled the equalizers, but nothing makes a difference. I don’t have XPrivacy installed.

BTW, I have the FP1 from the second batch, but I doubt this should make a difference … or could it??

It’s not entirely the same chipset, so in theory there is a small chance that it is different. If the chipset is the problem, I would image that there will be more audio programmes that suffer from this, depending on whether they use the system libraries or come with their own way of decoding audio files (or not, come to think of it - in the latter case it would be app-specific).

I used vlc to convert some flac files to mp3 files, they still play normally. It’s not a general issue with mp3 then on the FP1, and if they’re from different sources, it’s unlikely that they’re encoded in an exotic manner. This is difficult to troubleshoot without being able to reproduce…

No bluetooth/chromecast devices connected that may unexpectedly be an audio sink?

Bluetooth is off and no chromecast stuff going on. I can close the BlackPlayer app, start the pre-installed “Music” app and play my songs. This is frustrating. I wish there was a log file of the BlackPlayer app so that I could dig around there. So far no answer from the developer (I understand it’s one person). If I get any replies from them, I’ll share it here just in case anybody else suffers from the same problem.

I have also tried phone restarts, power off/power on and everything in the meantime.

A simple uninstall and reinstalling the app fixed this. It most likely was nothing Fairphone-specific. Thanks anyways, Johannes, for your thoughts and efforts.

I now have a really cool music player!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.