Black screen with a blue line and words underneath saying "factory mode" in yellow: after updating to 1.6 phone stuck while installation restart

edited
Dear Users

I’ve already found a Thread, that discusses a somewhat similar experience.
However I am not able to apply what’s happened there to my case.
(Maybe because of lacking technical knowledge)

The Thread I’m referring to is the following:

For me, it happened a little differently. I wanted to update from cajun to cherry as well, in a spur of a moment and didn’t think that there was going to be anything complicated about it. I had heard about the issues with 1.8, so I double checked, that the version my updater found was the 1.6. Since I had not heard about issues with the 1.6 version, and had problems in the last two weeks with my phone freezing or just restarting on it’s own, I thought updating might help.
So I downloaded the update, no issues und accepted the superuser access and restarted my phone. Walked away and came back after 10 minuts or sth and all I got to see:
Black screen, with a small blue line in the upper part - edit: there are now two yellow words underneath that blue line saying “factory mode.
Not even the android robot or anything.
My Macbook doesn’t react to connecting the phone other than charging it (at least I think it does).
This is my first smartphone, (first badge) I know nothing about programming, and I didn’t backup my phone, so I guess every photo and whatnot will be lost.

Does anyone have the nerve and can help me? I’ve already contacted the support team, but since it can take 5 workdays to get an answer and I’m scared to receive an answer like “install this and that file” but the thing is, I don’t even know how to “reach” my phone anymore, to get access to it so that I could somehow un/install anything on there.

I’m sorry for grammatical (or other) mistakes and my lack of technical know-how.

Thanks in advance
Charlotte

My advice is: Don’t worry! (…be happy…)
Since your phone doesn’t start up anymore, there is nothing you can do wrong, so you can just try some things and learn on the go! :slight_smile:

Thanks :wink:

The thing is, that I honestly don’t know WHAT to try. As I’ve said, my Macbook doesn’t seem to be able to connect to my phone and the phone itself doesn’t get to a place where I can do anything.
So I can’t actually transfer anything onto it.

The only thing I’ve managed to do (by combiningly pressing the power and the volume button) is produce to words underneath the blue line of my black screen. It says “factory mode” in yellow. It’s not not a menu though, so it’s not a process I can start bei using the volume button as in tutorials with the “android robot”.

So I’d be really thankful for ideas. Could it help to buy an SD card for example and put software onto it?

Hi @Socha,

I guess there is still a chance to recover your pictures etc.

Here is my guess: While updating, something went wrong, so the phone does not boot. By pressing Power and Volume Button, you entered factory mode. This is for hardware tests and largely undocumented.

I would try the following: Power the phone down, to be sure take off the battery for a moment. Then power up again. See if that helps.

If not,
Can you try to enter recovery mode? This page tells you how that works: https://fairphone.zendesk.com/hc/en-us/articles/201149588-How-to-boot-my-phone-in-Recovery-Mode ? Note that the display stays black while in recovery mode, you have to turn on the menu by shortly pressing the power button. Also note the strange navigation as described ion the link. Volume up is “enter”, with Volume down you rotate though menu items.

Please report back here if that works, so we can find out with you how to proceed from there. And be cautious while in recovery so you do not delete your user data.

Btw: A micro-SD card with 16+gb free space might be helpful for backup if you have one around.

Good luck!

2 Likes

Thank you, so, so much.
Taking the battery out and stuff was of course the first thing I did when it happened initially but that wasn’t helping. However I wasn’t able to enter the recovery mode beforehand because I just didn’t press those buttons correctly.

I bought an micro sd card today and after coming home I put it into my Fairphone and achieved to enter the recovery mode.
Out of the menu I chose the option “backup user data”, which was successfully completed. So I hope that means, that I really did backup my stuff (954 MB, is that realistic?).
Anyways, right now I’m reading threads and homepages to inform myself how best to proceed from here, since there are several options in the recovery menu and I’m not quite sure which option is the safest and easiest way to proceed.
Menu says:

reboot system now
apply update from ADB
apply update from sdcard
apply uptdate from cache
wipe data/factory reset
wipe cache partition
backup user data
restore user data

edit: my research suggests, that I download the update file onto my macbook, place it on the sd card, place the sd card in my phone again and choose “apply update from sdcard”, hope it completes the update follow up with “reboot system now”?

Correct. In that process, you might lose app settings. I wanted to try the recovery update myself to see what’s included in my case, but sadly I have not enough space on my SD card. :(.

It is important that you choose the right update file. See fairphone support pages.

Sorry I haven’t answered till now.
Of course, to make matters worse, I couldn’t find my sd card reader anymore so I had to borrow one from a friend. That card reader turned out to be broken, so today I had to buy a new card reader…
And now I’ve connected it and my laptop says it’s empty, that there’s no backup file on there even though my phone successfully completed a Backup, and the screen said:
Sd card free space: 4717 MB
User data allocated: 954 MB
userdata_201…343.backup
User Backup complete

So now I am doing the same thing again and I’m royally confused because the backup should end up on the sd card, right? A backup that’s saved onto the phone itself would make no sense.

Same thing. Backup completes, slightly different numbers, I take the battery out pull the sd card out, connect it to the laptop and - again - my laptop says it’s empty.

Regarding the SD-Card: Are there no files on it when you connect it, or does it says something like “this device must be initialized” ? Are you on a recent version of OS X?

You are absolute right, making the backup “on the phone” does not make so much sense. However this type of backup we are trying with recovery is not the “usual” way to do it, but seems like the only way possible currently.

You can proceed without the backup – risking to lose some user data. I have another idea how to get to your data thought, if you want to be a bit adventurous . Have you heard from support already?

My Macbook definitely isn’t the newest one, I changed the mainboard in 2012 I think so that’s that. But I didn’t have any issues with connecting the new sd card, I just opened it and saw that it’s empty and so I clicked Information and it said 63,x GB free space.
Copying the system update file from my macook onto the sd card was no issue whatsoever.
So I could have started my first manual installation attempt but I’m not quite ready to give up on those photos I took… I don’t care a bit about having to reinstall apps and stuff that’s really not an issue, maybe aside from forgetting passwords :D.

I’m just really frustrated that I’m not getting anywhere, and I don’t understand why my phone produces a backup file that doesn’t show up on my SD card. I’m confused.
I’d like to safe my data, and I’d be willing to try some “adventurous” ways because otherwise it’ll be lost one way or another as far as I’m understandig the mechanism of reinstalling the system update. I’ve gotten used to being cut off from friends, news on the go and the use of public transportation apps, it’s still no fun though…
Support hasn’t answered, but since they said, that it can take 5 workdays they’re still on schedule.

Here is my guess, why there is nothing showing up on the SD card:
Did you apply the Unified Storage Upgrade? Because if not, it could be that the partition, the recovery is referring to as “SD card”, actually is the second partition on the phone.

To be sure, you could install CWM recovery. It gives you the possibility to choose between “phone SD card” and external SD card. This is for the more adventurous user though!

I don’t quite remember if pictures on the phone stay unharmed by that update. They definitly should, but it can’t try that out currently. So, while is start experimenting with other ways to get to your data,you need to prepare you MacBook for the possilby following steps and install the Android Debug Tools. Here is how i do it: I use Homebrew, which helps installing advanced software developers and system admin typically need. They provide a very convinient way to install these Android tools you will need. Installing Homebrew is always the first thing i do on a Mac. Open a Terminal and enter the following line:

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

It gives you a text-based wizard helping you to install homebrew. After you have done that ( come here for help), you can install android with the following to lines:

brew update
brew install android-platform-tools

Come back here when you are readyto go on, i will try to access the files on my fairphone while in recovery.

Edit: Keep in mind please that i have no idea yet if that helps.

Edit again: It seems there seems to be no way to access the files from you Fairphone from Recovery unless you install CWM recovery. And it is actually possible that the option to backup to SD from recovery works only with Fairphone 1.6 and the Storage update.

However, the update should not delete data in Pictures and Music folders etc (right @Chris_R, @keesj ?).

Sorry i could not help you :frowning: , yet. My personal advice: If you regain access to you Fairphone, Backup your data the usual way (https://fairphone.zendesk.com/hc/en-us/articles/201190847-How-to-backup-and-restore-your-Fairphone) and copy pictures to your PC. After that, apply the so called Storage Update ( see the Fairphone Update). That will make you phone more future proof. Then, set up your Camera apps to save pictures on the SD card instead of internal memory (Settings -> Storage -> Default Write Disk).

1 Like

No I didn’t (tbh I didn’t even know about that Upgrade until a few days ago when I started my research on how to repair my phone). Thanks for pointing that out, that’ll be it. Man that’s just frustrating. Thanks again. I’ll have to think about how to move foreward…

@Socha Yes, that is frustrating. Hope you will be able to use the Fairphone again.

@ ben
Thank you for all the thoughts you put into my technical issues!
It’s not your fault all of this happened ;D.
I’m just too frustrated right now to do the manual installation from my SD card because if that somehow doesn’t work I am surely going to lose it. And even if it works I’ll still be frustrated with my empty phone and lost data.
It’s not like I have never saved pictures from my Fairphone on my Macbook before, it’s just been some months and I take a lot of pictures. I will apply the Storage Update though, thanks.
I can still hope, that the support will be able to offer some advice.

Thanks again for all the support.

You are welcome. Good Luck!

Hey there, it’s me again, I just wanted to report, that my fairphone still isn’t fixed.
I got an answer from the support on the 29th but due to an University exam and work related stress I didn’t move forward with working on my phone 'till today due to the level of frustration it already caused me up to that point and for fear it would cause even more.
Rightly so, because what the support offered as advice was installing the update manually (which didn’t work because my phone thinks that the divided storage space is my sd card and is therefore unable to locate the update zip on my sd card and because I can’t use the ADB connection because I can’t reach my phone with my macbook because phone and laptop are unable to connect.
So I tried to perform a hard reset which was the second thing that was mentionend and aside from losing everything data wise it did no good because while the manual states that my phone will reboot normally after wiping everything, it doesn’t.
Since my data is gone anyway, any suggestions about what I could do that doesn’t involve a working connection between my phone and my laptop? Because I can’t think of anything.

Try the hard reset again, maybe something failed during the process.

I’ve tried it three times before writing here, but thanks anyways :pensive: .

The thing is, the instructions say:
"Step 1: Preparation
Please note: this step is only necessary for FP1 users, if you own a FP1U (released mid-2014), you can go straigt to step 2.

Go to System Settings -> Backup & Reset -> Factory Data Reset -> scroll down and select “Erase Phone Storage” -> press the “Reset phone” button. Your Fairphone will restart itself and erase all content. After this is finished, proceed to Step 2."

However I can’t prepare my phone like that, obviously, because all I have access to is the recovery menu… I don’t know whether that’s the issue, but if it is… Let’s just say that I’ll have to regret ending up with a Fairphone of the first badge for the millionth time in this process…

Does this help you: Bricked Fairphone (xda Developers)?

Tip: After step 6, type adb devices into your terminal window. You will see if your Mac connects to your Fairphone.

Post back here, if you need further assistance. I’m eager to help you! :slight_smile:

Even though absolutely out of my comfort zone (I had to google where to find the terminal window), I tried the whole thing not just what you told me, but when I entered my Fairphone Update .zip in the terminal nothing happened, no package was sent to my Fairphone.

I have an issue with step four and I don’t know whether that might be part of the problem or root of the connection problem itself…
Step 4 says: Connect Fairphone via USB, boot into Recovery mode (hold volume up button, press power button)
BUT I can’t connect my Phone via USB and boot into Recovery mode after connecting, because if I connect it while still turned off, it immediately turns itself on because it starts to load the battery. I then see the battery symbol and when I try to enter the Recovery Mode, it doesn’t work, it simply gets me to the stuck black screen with the blue line. So I have do disconnect the phone take the battery out and have to enter the recovery mode and after entering connect it to the USB cable and the Macbook.

Afterwards I tried what you said to have a look whether I just didn’t follow the steps correctly or whether my Macbook and my phone really aren’t connecting and they aren’t…
I’ll copy and paste the last terminal interactions (with X and Y instead of my name):
X-Ys-MacBook:~ X$ ./adb devices
-bash: ./adb: No such file or directory
X-Ys-MacBook:~ X$