Black Screen/Booting Issue After FPOS C.073 Android 13 Update

Just as a heads up…
I have now proceeded to manually install the A13 Update for the FP4

  1. enabling developer options

  2. enabling usb-debugging

  3. enabling oem-unlock

  4. then unlocked the bootloader (normal and critical)

  5. changed the Toggles of the flash_fp4_factory.command to the following:

    AUTO_REBOOT=“true”
    DATA_WIPE=“true”
    DRY_RUN=“false”
    FRP_WIPE=“true”
    INTEGRITY_CHECK=“false”
    REBOOT_TO_BOOTLOADER=“true”

  6. Executed the flash_fp4_factory.cmd and then due to the change of the toggles rebooted into bootloader.

  7. Checked again in fastboot mode the current status with fastboot oem device-info (to see that device is still unlocked) and with fastboot flashing get_unlock_ability (to see if it delivers get_unlock_ability=1. Unlock ability was 1 so I relocked the bootloader accordingly.

I am now with Android 13 but I do not know what the heck that repair from Cordon was…

7 Likes

Hi all, thanks for all your helpful comments.
I am in bit of a pickle.
My FP4 screen has been damaged a while back (say 5 weeks ago or so) but it still functioned all right. I figured I would replace it the next time I dropped it if it got worse. Did not happen so far.

Recently, I kept ignoring the update my FP proposed. On the 12th of october, I started facing blackscreen. I do not recall really actively pushing the install update, but it could have happened by an erronous prompt in the touch perhaps. I was however not charging so this is not super likely (unless it can it start installing updates when battery is charged at high percentage but not charging actively).

All of a sudden, the screen does not work anymore. When restarting, the only thing i get is a faint black screen (somewhat lighted). I can shut off the phone by 30sec power button, but in restarting, i get the same black screen (somewhat lighted), no FP logo or blue dot, just but one vibration. Then it is stuck and backlighting goes off. Tricks to go to recovery mode also do not work, nothing on the screen. After that it seems stuck.

-I’ve tried opening the phone, tightening all screws, but also disconnecting and reconnecting the display specifically. Does not change.
-plugging it in the pc generates a “tudohduhtu sound” but no fairphone shows up in ‘this pc’ and thus no change of downloading my data/pics.

The pickle is this:
did

  1. I accidently push the update to go ahead and i am now facing the “black screen/booting issue”
  2. my screen stopped working actively because of hardware and only has a bit of black backlighting as a last dance so to speak.

Option 1 Seems a bit unlikely since I had no idea what a “custom ROM” was until today; so i assume i did not have it. 2) Seems unlikely because there was no physical recent trigger at that time and the backlighting gives the idea that the screen still the nondamaged hardware but the software steering it is wrong (so 1).

Tomorrow i will try to connect to the Dock at work which could display something. I am worried the phone will not be generating a VGA output (or whatever output it needs to show stuff on an external screen) before i am logged in with the pin…

PS: also today, it started vibrating obsessively (15 times or so, untill i pushed the power button briefly) as if someone called me. But if i call it myself: voicemail…

Sorry for my lament.
I will keep you posted as to the external screen trials tomorrow.

At the end nothing worked to get past the lock screen.
So I assumed to loose the data and did a factory reset, with this I was able to enter into the Android setup and managed to unlock the bootloader using my USB-C dock, then I installed A13 as explained in the official guide, and now the phone works again.
Well, I like the phone and the company, but loosing time and data because their fault is not acceptable at all…
Hope everyone can get their phones working back.
Thanks a lot for this great thread!

4 Likes

3 posts were merged into an existing topic: Random reboots After android 13 update

3 posts were split to a new topic: Issues with launcher after Android 13 update

Hi everyone,

Thank you for being so active on this topic and helping each other out. I read all your comments and shared a summary with the relevant teams. We’ll look into why after upgrading to Android 13, some Fairphone 4 devices experience a black display during/after boot.

It seems there is a connection between this issue and a previous installation of a custom ROM. The exact cause is still unknown so we can’t say if this affects every device with a custom ROM (or even devices that never had one).


Most importantly, what can you do if you encounter this issue after the upgrade? There are two options.

Option 1 - Try to fix it at home

Some users above had luck with the following steps:

  1. Connect a USB-C dock to your Fairphone. The dock must support HDMI output as well as input from a keyboard (and optionally a mouse).
  2. Connect an external monitor and keyboard to the dock. If all goes well, your Fairphone’s screen should appear on the monitor, even if the phone itself has a black display.
  3. Using the keyboard and mouse, first make sure all your data is backed up.
  4. Follow the instructions in the article Installing Fairphone OS Manually to unlock your bootloader and install a fresh copy of Fairphone OS with Android 13. :warning: This will wipe your data.

This option can be great because it lets you back up your data and in most cases will take less than an hour. If you encounter any obstacles, feel free to ask for help in this topic.

If you are not comfortable with manually re-installing Fairphone OS or you don’t have access to the necessary devices (dock, monitor, etc.), consider the next option.

Option 2 - Contact our Support team and request a repair

Follow this link to fill out our contact form. Our Support team will help you send your device to our repair center.
As I am writing this, the reply time to new requests is 3-4 working days. To help speed up the process, make sure to upload your proof of purchase in the contact form.

We are aware of one instance where the performed repair was unsuccessful. This has been escalated to the relevant team and shouldn’t happen again.

9 Likes

I’d just like to add some hints for people that want to fix the phone themselves:

  • I connected a monitor to my docking station via VGA and it worked as well (so HDMI is not a requirement. I used a Lenovo USB-C Travel Hub)
  • it only worked if no power cable was connected to the hub. Otherwise the external display turned black after a second.
  • I had to wait for a few seconds after the phone started before typing space + pin + enter on the lock screen. The backlight of the black screen of the phone changes it’s intensity. After that it seems to be ready to accept the pin.
  • Everytime I left the phone for some minutes, the external display turned black and won’t wake up again. The phone continued to run for a few minutes and then it died(?) (I could ping it via WiFi for a few minutes).
2 Likes

Hum, maybe i am having some understanding issues here… please help, if you can:
I do now have a USB-Dock from a friend and i was able to backup all my precious data :smiley:

That is the good part.

But now i am struggling with the install process at a very early stage. I did unlock USB debugging and i also enabled the OEM unlock.
But now i cant go on. In the process for unlocking the boot loader, it is now desired to connect a USB cable to the phone and connect via adb. To do that, i have to disconnect my docking station, at least i did not get it running with it connected. And when i try to connect it, it states:

./adb devices
List of devices attached
3ef1b6d9 no permissions (missing udev rules? user is in the plugdev group); see [http://developer.android.com/tools/device.html]

I think i need to confirm the connection on the smartphone, but i cannot, as the display, mouse and keyboard are no longer connected.

I have installed Fairphone OS in the beginning of this year, so i should know how to do this, but i have no idea, how to circumvent this :-/

Can anyone help?

Now that you’ve saved all your data I’d recommend to reinstall FPOS using the “Flashing with fastboot” method on

resp. for unlocking the bootloader start fastboot mode on the device using Vol Down + Power, connect the USB cable and use fastboot flashing unlock on the connected computer.

1 Like

Yeah, i am following the instructions from that page. and there it is stated, that i shall do the following:

  1. Type adb devices and press Enter :leftwards_arrow_with_hook:. You will see a pop-up on your Fairphone asking if you allow USB debugging on this computer. Tap **Allow

  2. Next, type adb reboot bootloader and press Enter :leftwards_arrow_with_hook:. The phone will now reboot into fastboot mode.**.

  3. While in fastboot mode, type fastboot flashing unlock and press Enter :leftwards_arrow_with_hook: . Follow the instructions that appear on your Fairphone’s screen. This action will wipe all the personal data on your phone.

I can enter the fastboot mode using Vol Down + Power, but i cannot use fastboot as it seems. It states:

./fastboot flashing unlock
< waiting for any device >

I will try to bring my adb key to the phone via sd card. That might help.

Steps 5 and 6 are only used to start your phone into fastboot mode (the same as pressing vol down while booting). So adb won’t help you further here.
<waiting for any device> show that your connected device (PC, notebook) doesn’t find your phone in fastboot mode.
What you can do here is

1 Like

First of all, thanks for your help!

So, when i enter the fastmode, it pretty much looks like this here:
Picture from google…

So i guess, i am in fastboot mode.
As i can connect using the cables using adb (but i cannot get permission), but not using fastboot, it sounds much like in the thread, that you linked and there the solution was to use another cable. Although i tried with 3 different cables (two of them were the same type), i will see, if i can find another cable tomorrow. But for now i call it a day. I have flashed this phone with this PC using this OS (Linux Mint) before. So mayber i just got to find the cable i used that time…
I will post the results tomorrow, if i have any.

1 Like

Yes, that’s the correct fastboot mode.
I agree it sounds strange that adb is working and fastboot isn’t. But still this had been mentioned in other topics too and using other cables, usb ports or another computer normally helped…
Keep fingers crossed for your case!

2 Likes

Alright, finally, i could to the fastboot. sigh

I used the same cable as yesterday but another USB port as yesterday. First, i had the same result, “waiting for a device” but after another reboot with the usb cable connected and the fastboot command waiting for a device it suddenly reported success and the phone asked me to confirm the unlock.

So i will now be able to setup the phone completely. Thank you for your help, Volker!

4 Likes

Great it has finally worked!
Seems that the fastboot mode is often a bit bitchy. :open_mouth:
With “another reboot” you’re referring to the phone (and not PC), right?

Yes, i rebooted the Phone while the Fastboot command was waiting on the PC.

1 Like

I never installed anything else on my FP4. It looks like the phone is operating behind the black screen. Calls ring, when I activate the camera by doubleclicking the button I hear the typical sound - just the screen remains black…
The fault disappears after a reboot before it comes back after some time…

Sounds like a different issue as the problem discussed in this topic always appeared during the booting process.

I can see phone screen on the monitor, but i cannot do anything. Mouse, keyboard and Fairphone touchscreen input don’t work.
I tried

  • ORICO 8-in-1 USB C Docking Station
  • Lenovo USB-C 7-in-1 Hub
  • a monitor with USB-C input + keyboard/mouse connected to monitor

My phone is protected with pattern instead of PIN, so “space - PIN - enter” does not work. When i press space nothing happens.

any hints would be much appreciated

Hi,
I guess, that when you say, that you cannot do anything, that you see a log screen?
In my case, this screen was a little weird, as the clock wag not fully visible and I could not see anything change until I logged in.

And the login is done as follows:
Press Space
Then enter your Pin
Then press enter

You should now see your home screen.
If not, begin again with pressing space and so on.

Sometimes I needed three tries, but I got in.

Maybe that helps?

2 Likes