Best USB-C to Audio Jack Adapter for FP4

They look basically like the same adapters to me, just adding an USB-C charging port.

I ended up buying the “GOOGLE GA00477-WW USB-C” adapter, simply because it was available at a local retailer:

So far I am quite happy with it. All media controls are working, as well as my headset’s microphone. Using this headset on my FP2, I often heard a hissing noise during soft parts of a song (e.g. in a intro). Now with the adapter on the FP4, this noise seems to be gone. Yay! (Maybe this means that the digital-to-analog converter is of a better quality than in the FP2?)

I thought you buy the adapter as there is no digital to analogue going to the USB :blush:

I have the apple adapter because a review showed it had a better digital-to-analog convertor than some phones (cough Samsung Galaxy S8+ cough) and it was only €10. So I would not be surprised.

1 Like


work fine with my FP 4.

Perhaps we could make a wiki with all the tested adapters?

1 Like

I created one, based on the SD card wikis,please add the adapter over there and use this topic here for metadiscussions


My fairphone 4 arrived and I tested the Apple DAC with the special thingy I have for my hearing aid that functions as a wireless microphone/jack-equiped sound streaming adapter.
I can’t yet comment on the quality, but I can say that the maximum volume was way too low. Much lower than the maximum I can get from a phone with a headphone jack. So low I couldn’t hear the subtle parts of a song.
I solved the problem by downloading a headphone sound booster app and increasing the maximum.

I think the problem here is that the default maximum for USB C audio out on android is set too low, it appears to be a common problem. The fact that such booster apps exist seems to support this theory.
I will do more testing and report back if I find evidence to the contrary.

If anyone with other brands of usb-c to audio adapter wants to check this, simply see if the maximum volume you can set when using the adapter is lower than when using the same listening equipment (headphones, earbuds, speakers, etc) on a phone with a headphone jack. Take care to not hurt your ears! :wink:


The Apple “USB-C to headphone Jack” adapter also works.
Audio tested with a video and mic tested with the voice recording.

@FairlyAutistic to keep the wiki clean, I moved your comment to the metadiscussion, but edited as well the wiki to include your advice

1 Like

I think, if it doesn’t charge it is not fully functional. Or does it charge with an other combination of cable and charger?

Moving to the metadiscussion. thanks for the hint that we might need to move to “problematic”. I did not add it, @OvO can you give some feedback?

1 Like

Tested again today with the exact same combination - I couldn’t reproduce the issue and simultaneous charging works now.
Edited as a fully functional audio adapter because the audio works - but I understand your view - thanks for the input.
If the issue comes up again, I’ll keep the Wiki updated.


The Delock 65842 works fine with fp4. Interesting is, that they say which dac Chip they use (cmedia cm119B).


I have tested some adapters because I wasn’t sure which ones would work. Of the 3 different models of UGREEN I tried 2 didn’t work(the “newest” worked). Another adapter from another brand did work.
These Worked:

These didn’t work:


I’ve been using the Fiio BTR3K, which technically isn’t a USB DAC but it can work as one. I’ve been daily-driving it in USB DAC mode and I haven’t run into any issues. Also added to wiki.


The working ones are DACs, the other, cheaper ones only mechanical adapters. They can’t work on the FP4. The list of compatible devices is a lot shorter, only some Huawei or One Plus models.

1 Like,5

Finally trace an audio adapter in a local shop. It seems to work fine for me.

Some more experience (I wasn’t able to update the wiki):

1 Like

Could you please check your link to the UGREEn, please (did you copy the link while logged in?)? It doesn’t work for me and I see a lot of UGREEN 90 products there on Amazon.

sorry, somehow colons found their way into the links, I removed them, the links should now work.