Battery switching from chargin to not charging every second

My FP2 didn’t stop switching from charging to not charging, it started yesterday so this morning the battery was empty and now the phone doesn’t start at all (I guess the charging/not charging switch is too fast to let the battery charge…). So right now, I don’t have a phone anymore…
I could find the exact same problem in this topic, but I couldn’t find any answer to fix this. Can you help me?
Have a nice day, Thomas

1 Like

At home I have 3 different chargers, two are working fine and with the last one I have the issue you mentioned. I just assumed the last one was incompatible with FP2 and I use the two others instead.
Hence I would suggest you to try a different charger :slight_smile:

1 Like

This list might help :slight_smile:

1 Like

Like mentioned above you probably need a different charger and/or cable and/or try a different plug, but since your battery is completely empty now it’s also likely you’ll additionally need to do a battery-reset as described in the #batteryguide.

Hi, yes I tried, I have the problem with two different chargers and one computer, and it began with all at the same time. Thanks

In this case, your USB port is defective and you will need a new bottom module. (I had this problem twice.)

Write to support, tell your problem and ask for a new bottom module. (Tell them also that you have checked your address in the shop.) If your phone was delivered less than 2 years ago, you will receive it for free.

Now, we have 13 days reply time. If you don’t want to wait so long, call them (+31207884400, Mon-Fri 9:30–17:30, not on Dec 25–26, Jan 1) or buy one on your own (for example at the Fairphone Shop or at Vireo) – “buying on your own” is not recommended because of unnecessary paying.


Ok thanks for the tip, I’ll try this.

1 Like

Maybe there is just dirt or fluff in your USB socket. Try to clean it with a toothpick or something like that.

Hello to all, FP2 with FP Open installed, same symptoms described by the OP with or without root/XPosed/FakeGapps. Went crazy during the weekend, because battery was charging perfectly just two days ago. Behavior became suddenly erratic, switching from charging to not charging and having sudden fake or real fast discharges. Checked for apps, none using too much CPU or related to the problem. Cleaned contacts and battery. Tried all the solutions in the battery guide, none helped. Realized then that charging was stable with a bad USB cable that I was going to throw away this weekend, one that didn’t allow for syncing. Then noticed that changing the USB configuration in developer options stabilized charging while the setting didn’t revert to its default (“charging”). Finally pinned down the problem: USB debugging needs to be turned on always for charging to be rock solid! I suppose there’s some bug in the OS that creates instability in the charging circuit once USB debugging is turned off. Phone is perfect again. Hope this helps other people having the same problem.

1 Like

Hey @Dr_Cool,
Did all of your tests happen while trying to charge from a USB port of your computer (that would explain a lot) or can you confirm your findings when using a wall-plug?

I edited your entry in the #batteryguide a little, as one single report is not enough to talk about a system bug.

Hi All,
So on my side it was effectively the USB port that was defective, I replaced the bottom module (25€ in the store) and now it works well.
Cheers, Thomas

1 Like

Tested with many different standalone chargers, cables and different USB ports. Without USB debugging “on” the system behaved always erratically, didn’t recognize the charger type (AC or USB) correctly and wouldn’t simply charge with some USB ports, although with other ports it would.

Do you use FP Open or Android system? I wonder if the bug only affects FP Open users.

Here an example of the problem in pictures, phone connected to computer USB port, no charging when debugging is set to “off.” You can see that the status bar icon only shows that it’s charging with debugging set to “on.”

I can confirm that not only good chargers but also good cables are important to solve charging problems. First, my FP2 with Open FP is unable to steadily charge with a charge-only cable (i.e. a nondata cable). Second, among functioning data cables not all have the same quality. I was having problems with one of them, a generic cable, and then realized that it’s thinner than other OEM cables from Samsung and HTC. The FP2 clearly doesn’t like cables with small wire gauges! Apparently this problem can happen with all smartphones that drain high amounts of current during the charging cycle, and the FP2 is one of those.

To summarize: make sure that you only use the best USB data cables with the largest wire gauges to charge your FP2, and make sure that USB debugging is set to on in the developer options menu.

1 Like

I’ve been having the same problem for the last 2 days and now the phone refuses to charge at all. I tried all the suggestions in the battery guide but nothing seems to work…
As I have a problem with my microphone too and am waiting for a new bottom module to be sent to me, I wonder if these two issues are interrelated and it’s just a faulty bottom module. In this case, I guess I should stop worrying about it and wait until the module arrives? Or is it possible that it persists even after I replace it?

I suppose they are, as defective bottom modules can lead to both problems you have (microphone and charging problems). So just relax and wait :sunglasses:

Does it work when plugged in to a wall socket? I had the same issue with FP Open Os. Since I moved to Lineage the issue has resolved itself.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.