Battery History Wifi active state bug?


it seems that there is a bug in the battery history. If I switch off my FP2 during the night, Wifi (WLAN) is “active” during this period:

I think this is a display issue and not a real bug. Can anyone reproduce this “bug”?

1 Like

Well, I also have this “problem” that WLAN is displayed as “active” when not connected (but is turned on). On the third day when I had my FP2 (10 Jan), the WLAN bar was displayed correctly (so there was no WLAN bar when WLAN was not connected).

I have the same issue. I was in flight more for around 10 hours with Wifi off, but it still displays the wifi as on in the battery page.

Have you tried if changing the accurary in location settings makes any difference? As far as I know “High Accuracy” will keep wifi running (listening) even though it’s not used for data. I don’t have my FP2 yet so I can’t test it.

In Wifi Advanced settings you can opt out of that and I think it’s disabled by default if I remember correctly?

Before I add this to the bugs list can someone post steps on how to reproduce this and can someone test (somehow?) if it’s just a display bug or if wifi is really on?

I think it is a “display bug” of the battery history.
My FP2 was switched off and showed an “active” Wifi during the night. I don’t think that the phone is able to have an active connection in this runlevel.

I guess that the Wifi state info is somehow not correct. Maybe this is related to the Wifi with exclamation mark (!) bug?

1 Like

I just tried disabling the High Accuracy Location setting and will check if this is of any use.
However, attached you can see a screenshot of the battery page. My phone was in flight mode as I was on a flight, and the Wifi still shows as active. (the large gap in Mobile Network Signal is due to flight mode, and I did NOT have Wifi active after I turned on Flight Mode)

I deactivated the precise location and switched to “device only” (GPS Only) and then switched off Wifi. it is not easy to spot, but the Wifi indicator bar ends a bit before the current battery level, so this helped.


I think there’s a bug. I deactivated Wifi, deactivated the option for the Wifi to scan even if it’s off, and I deactivated the location services. Still, the Wifi shows as active in the battery page.

I was debating with friends of what between 4G and Wifi consume more battery so I let 4G off for few hours this morning and Wifi on. Then at 2pm I switch off Wifi and on 4G. I had a phone call (20min) just before, we can clearly see it at the middle.

As you can see, the wifi looks still active.
The option in Wifi ‘Scanning always available’ is off, location off but in when on it is in ‘high precision’.

I will try by setting it off, but since location is off, it is not supposed to affect the Wifi, right?

Edit: also the phone seems “awake” on the graph when wifi on. I didn’t really use it, the screen was off, etc… Strange.

Edit2: it seems way better with high precision off! Really strange. And when I active location, it is automatically set again in ‘High Precision’.