Battery drain in FPOpen

Hey there!!

I recently got (at last!) my Fairphone! I am quite happy about it, but I feel that the battery drains quickly. I got a duplicate of my old sim card, and things got a bit better. However, It is still to be improved.

When looking at battery stats, I can see a high percentage of “Miscellaneous” consumption (38%). Miscellaneous, according to Android’s description, is the difference between the computed approximated power use and the actual drain observed in the battery. In the last cycle, I have got a 38% of Miscleaneous, with

-Computed power use 1010 mAh

  • Observed power use 1887 mAh.

I wonder if it would be better to use Lineage OS.

Any tips? Thank you

P.S.: I’d also like to decrease the vibration power, it is too strong! It sounds a lot!!

Check out the #batteryguide for some pointers.

This looks exactly the same with me.

Now Idea, whats the reason.

Hey, I had similar problems, for me what helped was disabling the Stock email app and using K-9 mail instead. Also there is an app called Greenify which can analysis you apps and you can set it to hibernate those process which are causing a drain when your phone is asleep.

It could also be one of the Unified NLP back ends causing a drain if you are using MicroG as a replacement for Google play store.

I used K-9 and deactivated all apps which I never used. I tried to find out the problem with better battery stats, without success.
Last week I installed a fresh FPOpen with almost the same apps and the same google services.

The battery last the hole day now.

1 Like

This is one of the reasons I am crawling back to Google.

This drainage comes very random, and especially when happening 1:00am at night, it manages to drain the battery before it is time to go to work (hence, no alarm). And also only using stock email program, but then why doesnt the email program show up in battery stats as the cause?

Best guess I had is that this could be some wifi-handshakes taking place, or some app wanting a gps fix (desperetaly), because (sometimes) if starting the gps once a day, kept the problem away.

A fix that deffo solves this drain problem is a restart a day.

(another reason switching back to Google services is the lack of support for typing in Swedish on the keyboard. Yes you can type with Swedish characters, but without any words in dictionary it is worthless)

Well if I would type in Swedish, that would certainly be the case as I don’t speak the language, but if you’re Swedish yourself I think you got me slightly more worried for the so-called First World than I already am :wink:

As for the problem … did you try a re-install? (Success story is right above your post.)

Sorry for waking up a 28day old post (see it now), and BIG thanks for linking in an easy way of just re-installing.

It is now when I actually tried to re-install I remembered why I haven’t tried that yet. I (stupidly) decided to encrypt my data folder, which means that trying to re-install now would probably not work, because I can’t wipe the data-folder (including the dalvik cache), and have a feeling that could make the install fail.

I will try leave this thread alone until I find a way secure way of re-installing a encrypted FPOpen-device, and maybe then confirm if the battery drain (by miscellaneous) is gone or not.

  1. Encrypting is not a stupid decision.
  2. The only step you need to add with an encrypted data partition is to not only wipe, but to format the data partition (there’s a button for that somewhere in TWRP), the encryption (and all the data) will be gone then.

Ok, this could then work. I have a pretty fresh backup, so this is Purrfect!
Thanks for being my brain (while being under a vicious cold and brain only using one core at 0.4Ghz).

Wish me luck (now that I have a clear path ahead)

Just in case you have a TWRP backup, be aware of the exclusion of your personal stuff in Internal Storage … .

I wish TWRP could do it all in one go, and not have to manually store all personal stuff. Making backup more easy is on my “shit-list” of things to do, but never get done.

I use MyPhoneExplorer’s “Multi-Sync” for that … one go, and all the personal stuff TWRP leaves out is on my PC :slight_smile: (don’t know about App settings though, but I don’t need those for now).
But it’s Windows only.

This topic was automatically closed after 182 days. New replies are no longer allowed.