Backup sd card data before formating to FAT32

Hi there,
My Fairphone 2 doesn’t recognize my 64 GB micro sdxc sd card.
How can I check if is formated to exFAT?

I have tons of data saved on it, which I need to backup before reformating as support explains here

How do you suggest I do it?

Thanks in advance

OK you need to read a SD card which your FP OS doesn’t mount.

You could try plugging the phone to a PC via USB, it’s possible that the PC will be able to read it. (in UMS mode, the phone is only behaving like a usb card reader)

Or if this doesnt work, you would need another mean to read it, like a laptop with SD slot, an external SD reader, another phone, …


Hi thanks for advice
I was able to copy some data from my 64gb onto my computer using my old sg4 phone and Androïd file transfer app.

My problem is the sd card is the default storage for all apps and data on sg4. Most of the sg4 apps are saved on it, but I cannot access their data from my computer, hence do a proper backup

How can I access this data and make sure it’s safe before


I was able to copy some data from my 64gb onto my computer using my old sg4 phone and Androïd file transfer app.

Do you mean you are using an app ?
I would advise to simply connect the phone on USB, mount the sd card and copy files directly without any app.
IE, if you are on windows, you will see a new drive letter and copy files from it.

Thanks Jaymanu,
I am on Mac. When I plug the Fairphone with the USB only, it doesn’t show up on the Finder, nor on the “Disk Utility” Do you know how to access data without using an app on Mac?

Do you use a data cable to connect your phone to the computer? If so, as soon as you have connected your phone to the computer, you get a message on your phonescreen that your phone is charging. Tap on this message and in the following screen you will see the options including MTP.

Thanks Lidwien,

I tried as you suggest, but it doesn’t work. I am using a Mac 10.9.5.
In the USB conection menu on the FP2 I tried all option (MTP, PTP, and Mount SD card) but the FP2 does not show up in the finder, nor Lightroom detects it.

I would really prefer not to use any app to access data on my FP2 from my computer. Do you have any solutions?

Well at least you know it is a data cable you use.
Sorry, I can’t help you further as I have no Mac.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.