Backup on Signal messenger fails: both transer and chat backup installation stops running

Hey @all,

I moved from an FP3 with /e/OS to an FP4 with stock rom and am having problems with the Signal messenger backup.

When I try the transfer option, the transfer loads to about 40% and then crashes. The same thing happens with the backup over the datastore, I can start the installation but Signal crashes.

Could this be a problem with the switch from /e/OS to FairphoneOS? or is it a problem with the messenger itself?

Could someone solve this problem?

I’m not sure if I’m reading this correctly, so just to make sure: Does the Signal backup on the old phone still run without issues and the problem is “only” the transfer/restore?

1 Like

From my experience the backup can be restored on any other device presuming you have the unlock key :wink:.
But I guess what you describe is a problem, transferring the backup files from the old to the new device, right?

How do you try to transfer the file? Have you tried with adb already?

I restored my FP3 Iode OS back-up on the FP4 with FPOS without issues and neither have issues to do backups on the FP4.

@mde I have not tried if the backup runs on the old phone, because then I would have to erase the memory of Signal and thus possibly lose the data.

@Lars_Hennig I have the unlock key and the process works so far, the loading buffer appears and the app crashes afterwards, see pictures:


Unbenannt

I transferred the file via the SD card. Does using adb change anything? is not it still the same file?

And here the process, when using the nearby transfer:

It crashes during the transfer.

Ok, sounds like it’s my backup. Maybe it is due to interfering data in the backup, or the backup is not readable properly.

That was not my point, that would be a restore, not a backup :wink:
My point was: Does the backup process actually work without errors? I had a case last year where some old images in Signal chats were corrupted and so the backup itself failed. I had to find and remove those images before it worked again.

Thank you, this is a good hint! The backup process seems to work correctly, the file is created. But I have a sneaking suspicion that it is because I once accidentally created such a Signal SMS group and could not delete it properly. I will look at all the images and try it again.

How can I detect these corrupt images/files?

What I did: Signal settings → Data and StorageManage StorageReview Storage → check for media where the preview does not work, this is a good hint that something is broken. This is also a good way to find and remove files you don’t need any more anyway and make your backup smaller. Depending on the amount of data this is not exactly fun, though, as I found no direct hints from Signal what might be broken.

2 Likes

Ok, I deleted the pictures where the preview didn’t work and also all the voice messages. It’s now only 63 MB, but it still doesn’t work. :face_with_diagonal_mouth:

Have you tried to transfer the backup to internal memory instead of SD card? Think thats how I did it, and I did not remove pictures etc…

And: do you already use Signal on the FP4, because I think restore is only possible at initial set up.:thinking:

Hey Yvonne,

yes, I transferred the backup to the internal memory and then copied it to the SD card. I also tried sending it via messenger, that didn’t work either. Maybe I should try again by transferring it to my PC and then the new FP.

I tried to restore during the initial setup.

Another thing I need to try is updating /e/OS on the old Fairphone. I was too lazy to do that at the moment :smiley:

I will give an update if it works :slight_smile: