Avoid bootloop/bricked FP4 when flashing /e/OS

Maybe the system was trying one of the slots which was “unbootable”. So it tried to boot that about 6 times and changed to the other (bootable) slot then.
You can check that if you want by going to Fastboot mode and typing in fastboot getvar all and searching for unbootable slots (slot-unbootable).
On unlocking the bootloader I’ve just seen my device rebooting for clearing the data partition and rebooting again a second time after that.

1 Like

Hi guys.

I’m new here, as I received my Fairphone 2 days ago and installed /e/ almost immediately.
Just to keep you informed that as of yesterday with up-to-date software, bootloader issue is still there :slightly_smiling_face:
Anyway, glad to have a functioning /e/ OS and a great FP4

As with @Azimoth , I was able to successfully install /e/OS on my new FP4. But I did NOT skip the last section and this was my undoing. I would rather see the warning that be stuck in the locked bootloader.

I think some steps are missing from the instructions…

@Volker I see the following with your suggestion
How were you able to switch into the bootable slot?

Any help here would be great.

Which active slot is shown by fastboot getvar all?

You may try fastboot --set-active=b.
but maybe this command won’t work as you seem to have relocked your bootloader.
You may just try to boot several times and the phone should automatically switch to the other slot.

Did you already try to unlock the bootloader again by fastboot flashing unlock?

1 Like

Slot a ist active

Both commands are not working.

fastboot --set-active=b

Setting current slot to 'b'                        
FAILED (remote: 'Slot Change is not allowed in Lock State')


fastboot flashing unlock

FAILED (remote: 'Flashing Unlock is not allowed')
fastboot: error: Command failed

Well, I’m afraid it doesn’t look too promising… :frowning:
What’s the output of fastboot flashing get_unlock_ability?

Did you try to boot various times? The mentioned getvar all command should show the remaining attempts for slot a.

You still might try out another factory reset.

If nothing helps you’ll have to have a look at

1 Like

fastboot flashing get_unlock_ability

(bootloader) get_unlock_ability: 0
OKAY [  0.001s]
Finished. Total time: 0.001s

fastboot getvar all
alway gives the following despite numerous reboots (no indexing of counts etc)

(bootloader) has-slot:modem:yes
(bootloader) has-slot:system:no
(bootloader) current-slot:a
(bootloader) has-slot:boot:yes
(bootloader) slot-retry-count:b:7
(bootloader) slot-unbootable:b:no
(bootloader) slot-successful:b:no
(bootloader) slot-retry-count:a:6
(bootloader) slot-unbootable:a:yes
(bootloader) slot-successful:a:yes
(bootloader) slot-count:2

Thanks for the tip and link, will take a look.

How do I do a factory reset from the bootloader?

fastboot erase userdata
fastboot erase metadata
allowed commands in the status of your phone? They should do it.
But honestly I’m not too optimistic for your device except a repair at Cordon…

1 Like

Ok, yeah, I tried those commands already. Same locked error as the other fun commands.

Nein…nein… Trotzdem vielen Dank!

Doesn’t /e/ ship with a recovery you could use to wipe data / factory reset? (I’ve never used /e/)

What happens when you use fastboot reboot recovery, select Recovery mode in the bootloader menu or boot into fastbootd (fastboot reboot fastboot) and select Enter recovery? :thinking:

1 Like

Both procedures just restart to the bootloader.

Thanks for the idea with the recovery image.
fastboot flash recovery recovery.img

Sending 'recovery' (98304 KB)                      
OKAY [  3.865s]
Writing 'recovery'                                 
FAILED (remote: 'Flashing is not allowed in Lock State')
fastboot: error: Command failed

fastboot boot recovery.img

Sending 'boot.img' (98304 KB)                      
OKAY [  3.625s]
FAILED (remote: 'Fastboot boot command is not available in locked device')
fastboot: error: Command failed

Is there another way to boot from the image?

No, sorry, booting an .img needs fastboot boot and that only works with an unlocked bootloader.

So /e/ really doesn’t have a recovery, huh? :astonished:

They (/e/) have a recovery. But if I remember well, if the device does not boot because of a “corrupt” system you can’t reach any recovery system…

1 Like

Indeed, it gave me a corrupt system error before locking me into the bootloader. :cry:

1 Like

I assume its like here, with the difference you cant unlock the bootloader again…as you have get unlock ability=0

Just adding as there are screenshots on gitlab

1 Like

Interesting :thinking:
I only asked because the last user with a bricked Calyx install could still access recovery.
Maybe A11 vs. A12 makes the difference here? A12 moved recovery to fastbootd.

Either way it didn’t help in the other case, so it probably wouldn’t have made a difference here, but you gotta try everything :slightly_smiling_face:

Well, that only leaves #contactsupport I’m afraid :see_no_evil:

I think this is the problem I described in the other thread. Connection (USB) interrupted, no access to enable debugging and you are stuck in the bootloop loop. I could also query all possible parameters via fastboot, but changing was not allowed. Without sending the phone in, there is probably no solution yet.

If I guessed correctly what you mean, I asked for it.
If not, never mind.


You indeed guessed correctly!