Astrill VPN causing a crash?

Anyone using a VPN app ?
Recently (using LOS15.1), I can’t start Astrill VPN anymore. It’ll make the phone freeze for a second and then crash and reboot… I can’t even log in.
I’m talking with the Astrill support team but so far we didn’t find any solution.

OpenVPN works fine here. Another user mentioned s/he was using Blokada (a local VPN) without issues in the protocol level.

Both ProtonVPN and PIA VPN are fine as well.

I see … in China, Astrill VPN is one of the best for accessing the world. I purchased an account there, but since I’m on Android 8.1, it seems that their app is not supported any more.
If you guys use other VPN without any issue, I guess it should be related to their app only.

Just got an answer from the Astrill support. They tried a lot of things but nothing worked so far.

After telling them my phone configuration, they told me the following :

Anyone has any idea about this ? Since i really need that vpn to access Google and WhatsApp or Facebook in China, do i have to downgrade to LOS 14 to make it work ?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.