Apps File Manager with Root

Hello everyone,
one question please: which file manager do you use, which has root permissions?
I’ve tried 4 or 5, but I can not move a .ogg file to the / system / media / notifications folder.
Oh I forgot: I upgraded to FP Opne 18.02.0
Thank you all! :slight_smile:

I use Amaze.

Do you get an error message?

1 Like

Hello, thank you very much for your reply!
I also tried with Amaze.
No error message: it appeared to me “operation completed successfully”, but in reality it had not done anything … :confused:

I don’t have any .ogg files at hand right now, so I just copied one from there to another lokation, renamed it to “0.ogg” and moved it back. That worked without problems and now I can use “0” as the notification sound in Settings.
If the same works for you too, then it’s probably an issue with the file you want to copy there.

/system normally is mounted read only. You need not only root, you have to be able to (temporally) remount /system read/write. The file manager might be able to do that


So you advise me to do it from TWRP?

@paulakreuzer do not think depends on the file, because if I open it when it is in the sd it plays quietly.

I remember amaze once asking me for some special permission, but I believe it was to modify the external SD card, not (explicitly) the /system partition (too).
I should add I’m on Lineage OS. Maybe there is a difference between Android 6 and 7?

As far as i remember,/system is r/o since kitkat (at least that’s when i started with Androis :slight_smile: I’m also on lineage. Maybe amaze does the remount for you, i don’t use amaze

$ grep system /proc/mounts
/dev/block/platform/msm_sdcc.1/by-name/system /system ext4 ro,seclabel,relatime,data=ordered 0 0

shows ro, so read only

1 Like

I´m using classical TotalCommander for any file actions on my stock FP2 Lollipop. With it I can also write to the internal memory in a limited way e.g. also into the “notification” folder. It shows “RWX” properties for the main folder.

It generally uses Java functions and offers full Root functions optionally on a rooted device.

1 Like

I guess then there’s more involved:

FP2:/system/media/audio/notifications # touch x
touch: ‘x’: Read-only file system
1|FP2:/system/media/audio/notifications #

You need to enable root for Amaze, in fact. Can be done here: Settings (in the lateral navigation drawer) → Advanced (bottom) → Root Explorer
(in Spanish: Ajustes, en el menú lateral de Amaze → Advanced (sic), abajo del todo → Explorador Root)


Yes of course, that’s what I did too :slight_smile:

However it seems that I have solved with TotalCommander.
Thanks to everyone for the tips !:relaxed:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.