Apps don't respond

Almost every time I try to open an app, I get a pop up saying “name of app isn’t responding. Do you want to close it?”. I tried updating all the apps I use frequently and deleted some unused ones, but it still happens as often. Does anyone know how to solve this, please? Am I the only one experiencing this?

The first thing that comes to mind is deleting cache of the affected apps. If this doesn’t help, clear cache of the phone. The last resort would be deleting app data one by one and doing a hard reset.

####Here is the procedure:

  1. Go to Settings > Apps > All Apps > [Affected App] and choose Clear cache. Do so with all affected apps. Proceed with the next step if your problem is not solved.
  2. Go to Recovery Mode and Clear Cache. Proceed with the next step, if your problem is not solved. Attention: The next steps involve the loss of user data. Do a thorough backup beforehand!
  3. Go to Settings > Apps > All Apps > [Affected App] and choose Clear Data. Do so with all affected apps. Proceed to the next step, if your problem is not solved.
  4. Do a hard reset. All your data will be deleted, and the phone will be set back into factory state.

Please come back during the process and tell us how it goes.

I have exactly the same problems, many apps are giving me this message, some apps don’t work properly, like SnapChat and A Color Story. So I went back to factory state, this morning… Unfortunately, it doesn’t make any difference at all, still the same problems with many apps.

I have Kola Nut 1.8.7, so that’s okay, too.

My next step is removing a lot of photos, hope that that will work?

Any creative ideas are welcome. Could it be this phone is getting too old? First batch here…

The photos could be the problem. If the app has to load a lot of photos in a directory, it might give this message. Try to move photos to another folder, or split them up in multiple folders.

The phone is not too old. I get this message very rarely, but I also don’t have a lot of photos on my FP1…

Will report back when I have deleted most of my photos. The factory reset was a suggestion by the helpdesk in Amsterdam I called, btw.

Bad news, have removed all my photos, but still apps like A Color Story, Snapchat, Facebook, Whatssap, Instagram, keep giving me this pop up saying they are not responding, or just close down in the middle of things. Getting quite desperate, as I really want to be able to use those apps. A Color Story and Snapchat have never worked properly since I installed them. What else can I do?

Have you tried the things I posted up here?

Yes, I have given a hard reset, so yesterday morning the phone was back to the factory state, and I started back from scratch with it.

Same problem here. It happens to me every 3/4 months. Last time it came together with the power button becoming not responsive and I had to send the phone for repair, they changed the motherboard. Now it’s very slow again and very difficult to work with. I might try a hard reset one more time, and if not send it again. Honestly I’m very sadly reconsidering to change phones…

Same here, still, the phone has become a little less slow now that I have given it a hard reset, but every day I get these annoying messages that apps are not responding. This goes not only for exotic things like SnapChat, but also for everyday apps like WhatsApp. Highly annoying. I also called FairPhone, they said they’d never heard of this problem before, would discuss it, and come back to me. Never heard anything, though. There are quite a couple of people who have bought a FairPhone because of my (initial) enthusiasm, and now I’m considering to buy another phone. Feel pretty disappointed…

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.