AOSP-Keyboard and autocorrection=off does autocorrection

I use the AOSP-keyboard on my FP2 (OS 1.3.0) and have auto-correction (deutsch) switched to off, because I can do better, than the machine.

But the auto-correction seems to be on, because it changes several words without my permission/interaction. I have just been in Danmark in the town “Ribe” and when I reported from there via messenger, the autocorrection changed “Ribe” (without quotes) to “eine”. Just now I asked someone how his connection-speed is, the word in German is “Verbindungsgeschwindigkeit”, and I got “Verbindung süß chain dicke it”. Back came: “It’s 10 o’clock you are already drinking booze …”

Has anyone an explanation for that behavior? (No, not the booze!) And how to change that. And I don’t need an answer, how to include words into the dictionary …


1 Like

There are 2 different settings to switch off:

Here is the solution: goto Settings/Language+input/Android Keyboard/Text correction. You’ll see “Auto-correction: Spacebar and punctuation automatically correct mistyped words”. Tap on that item and you get a check-window, where Auto-correction ist set to “modest” and therfore is working though you disabled the Spell checker. Set this to off and auto-correction is really off.