English

AOSP GSI: Can't receive texts (but sometimes can)

Hi all,

I have a peculiar issue that I want to share here in the hope of getting it fixed… At the moment I have a Fairphone 3 for about 5 months or so and I have installed an AOSP GSI as a custom degoogled Android ROM. I’ve been using it happily for 4 months or so, but a month ago I switched providers and now I’m having trouble receiving texts.

The timeline so far:

  • It worked on the first couple of days of switching (I think)
  • Noticed I wasn’t receiving people’s and company texts for the week after (roughly)
  • Called my provider. Everything seemed OK and the SIM worked on my old phone too. They were going to look into it.
  • Started receiving texts again a week later. Provider said they did not change anything in the end.
  • Not receiving texts again another week or so later (same issue).
  • Called provider again. They switched my SIM, still nothing.

I have the feeling it’s not the problem of my provider. It seems to be either my custom ROM or my phone that’s malfunctioning. I’m currently trying to rule out which one it is.

I’ve looked into other topics mentioning this problem but no success… SMSC settings are fine, rebooted a billion times.

Last resort would be factory reset or installing a different ROM, but I REALLY don’t want to go there…

Hi and welcome to our community! :slight_smile:

One question that sometimes gets overlooked in this context: Did you use an iPhone before the FP3?

2 Likes

Hey, thanks for the suggestion and the warm welcome! Good point, no I have not used this SIM in an iPhone.

EDIT: btw, I’m not sure it’s related to the ROM, is the title change relevant in that case? :slight_smile:

My question isn’t really about the SIM. If you used an iPhone before the FP3, other iPhone users probably keep sending you iMessage (?) messages (that cannot be received on non-iOS phones, i.e. Android phones etc.) instead of standard SMS messages.

1 Like

Right, so my number was never linked to iMessage. I had an iPhone ages ago but my previous two phones were not iPhones (and had perfectly fine bidirectional SMS).

1 Like

Swapped my SIM with the SIM of another phone, was able to send bidirectional SMS between the phones. So my phone works fine with a different SIM and my SIM works fine of a different phone. So that’d mean my SIM SPECIFICALLY doesn’t work for my FP3?

Confused.

Was the other SIM a SIM of a different provider?

Correct. Specifically: my ‘problematic’ SIM is of T-Mobile, the other SIM was of Tele2 (both Dutch providers). My old provider was also Tele2 (which was working fine). Maybe it still has some ‘old’ settings that cause it to work on Tele2 but fail somehow on T-Mobile?

You could check the APN settings, whether they are correct and comply with those of your provider. Otherwise it may be an icompatibility between this provider and the FP3.

As far as I know APN settings are just for internet and MMS. Couldn’t find anything on SMS settings for APN. Tried typing *#*#4636#*#* to check SMSC value but it seems to be set to T-Mobile ("+31624000000",145).

I can’t imagine incompatibility. T-Mobile is the biggest Dutch provider (and FP is Dutch!).

1 Like

Did you contact FP support?
Or otherwise, as I saw you want to install LOS, keep us updated about whether it works again.

That will not work very well with a GSI installed, Fairphone don’t support this :wink: .

GSIs should be considered experimental stuff for developers. If in the end it turns out the GSI was at fault here, it would not be a surprise.

1 Like

Installed LOS today, texting is working fine now :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.