English

Android 9 - no Internet Access

Dear Helpers,
Although access to mobile data is active, every relevant application (e-mail, browser, Twint, …) says “No internet access”. I have set the APN to Swisscom 4G APN Settings for Android - 4G 5G APN Settings according to the instructions, but no success. Also Samsung Galaxy A32 5G - Richten Sie Ihr Handy für das Internet ein | Swisscom leads to exactly the same settings (but with proxy and port information). Then I tried to have Swisscom send me the set-up, but this route leads to Mobile Geräte: Handy & Tablet Hilfe & Support | Swisscom, where FP2 does not appear either. None of the search results for “Swisscom 4G APN Settings for Android” are successful - so what is the APN setting for FP2 with Android 9 for the provider Swisscom?
I had no problem with my FP2 in the previous state of Andoid (version 8).
My Current settings (some with alternatives, which also did not work):

Name : Swisscom Services
APN : gprs.swisscom.ch
Proxy : Not Set or 192.168.210.1
Port : Not Set or 8080
Username : Not Set
Password : Not Set
Server : Not Set
MMSC : Not Set
MMS Proxy : Not Set
MMS Port : Not Set
MCC : 228
MNC : 01
Authentication Type : Not Set or PAP
APN type : default
APN protocol: Ipv4
APN roaming protocol: Ipv4
Enable/disable APN: APN Enabled
Bearer: Unspecified
MVNO type : None
MVNO Value : Not set

Should no one have he settings I assume Swisscom support would be able to provide. At the end they are provider and not really phone specific, just the wording in the settings might be slightly different. Perhaps it helps to delete and re enter from scratch

Thanks yvmuell,
Since living in Zürich I already considered to go to town into a Swisscom shop and ask them for help
And yes, since I have listed all the data I can try Your suggestion to delete and enter from scratch. “Same procedure as every year…”
… but this did not help either.

And you have set Networktype to 4G? Not that it is set for whatever reason to 3g or 2g?

Of couse, I have only 4G activated, 3G is out of service already now (or at least soon).
I have also tried the following:
Switch phone off
Remove and re-insert SIM card
Start phone again
→ no positive effect, that is, no ‘initial connection’ to the provider and hence no automatic setting of appropriate APN parameters.
→ Have scheduled a visit of the Swisscom Shop tomorrow monday…

Is only mobile data not working or the SIM card doesn’t register in the network (empty symbol) In the latter case: Is it a new SIM card or is it from your former phone? Sometimes a simple SIM card exchange does the trick.

2 Likes

Amber,
today I consulted a Swisscom shop which diverted me to the Migros Electronics shop (my contract is Migros Budget). It turns out that the APN nevertheless is from Swisscom…
And so we tried a new SIM card in hope that it will register properly.
→ The APN parameters received are the same I already had with the previous SIM card.
So at the time being there is still no Internet Access… although the 4G sign is OK.
Is this a quirk of the updated OS? A known error - or may there be a hardware problem?

Can you rule out a malfunctioning Firewall app?

2 Likes

Sorry for not having checked this post earlyer: I’m not awaare of a firewall app on my FP2 - have just checked all Apps again.
I’m in contact with FP support, but did not hear from them yet.