English

Android 7 Nougat has made my FP2 extremely slow - how do I downgrade back to Marshmallow?

Hi all,
I upgraded my FP2 on Thursday to Android 7 (via update launcher), but I’m very unhappy with it.
My favourite apps are not usable any more, the whole system is extremely slow (it was never fast, comparable with other smartphones, but now everything freezes or directly aborts).
I already rebooted several times and reinstalled the respective apps.
Permanently I receive error messages “…does not respond”
The apps worked well directly befor the upgrade - so there is no other app version which may have caused this issue.

How do I revert this Android 7 and downgrade back to Marshmallow?

Thanks in advance for your help, it is really appreciated,
Katrin

Sounds like something went wrong during the upgrade process. The first thing to try is usually to manuall reinstall the OS and/or perform a #dic:hardreset. Do you have a current backup of all your important data?

1 Like

Hi,
I don’t have a backup (apart of some photos I don’t store important things on my mobile).
But I’d like to keep the apps I have on my phone so the backup option within the FP menu doesn’t seem to be the right approach :thinking:

Hi again,
I found an app for the backup and started…it wil take 4 hours for the backup…
What happens next? How does such a manual reinstall of the OS work and where do I get the download from?

Assuming you were using Fairphone OS (luckily for your intention to go back, at the moment they still offer the old version there):

For Fairphone Open OS, they only have the new version of the “Manual Installation” file already here, but freshly installing the phone might resolve the issue without having to downgrade:

https://code.fairphone.com/projects/fp-osos/user/fairphone-open-source-os-downloads.html

Hi AnotherElk,
sorry, I’m not familar with this - and I’m not sure which OS my phone runs with …and do I simply download and install it?

In that case you should most probably go with Fairphone OS, instructions are on the page I linked to.

If you want to be sure … what exactly does it say in Settings - About phone - Build number?

something-gms-something means Fairphone OS, something-sibon-something means Fairphone Open OS.

Hi AnotherElk,

sorry, it nothing you mentioned - under Build number I only have “18.09.2”

Ok, it’s Fairphone OS.
Fairphone Open OS would be 18.10.0.

o.k. - good to know - but I’ lost now :disappointed_relieved:
What exactly I have to do now ?

…it took a while…
I’m not sure everything went correct…
Now the phone is unusuable…
I only get error messages saying process “android.process.acore” and “android process.media” was stopped.
After confirmation “o.k.” the same message appears again and again
Reboot doesn’t help, it takes ages, ending in the same loop…

Were there any error messages?

Can you still reach Settings - About phone - Build number?
If so, what does it say now?

Edit: If you can’t even reach Settings anymore, if it was me, I would just try the install procedure again.

no error messages except the ones I mentioned above…
Tried to restart the whole process, but was unsuccessful to come back to the bootloader modus again

…some apps were “optimized” in the meantime.
Then I got the error message saying Android may behave instable as long as I don’t reset to factory setting.
Charge went down to 28% within a few minutes (was 80%+ before) and the phone is getting quite hot…

How so? Keep Volume - pressed while starting or rebooting the phone until the Fairphone logo is shown, that will be the bootloader (aka Fastboot mode) then.

That could be something to try, too …

no chance to reach the settings…seems to be in the save mode in the meantime, but no other error messages than the ones above described

Volume - and power or Volume + and power always end up in the "Fairphone logo with running dots, nothing happens except running out of charge

I give it up for today - hopefully it charges again to retry tomorrow evening, impossible to power off at the moment

Booting into recovery mode (Volume +) can fail, if the recovery is broken. Rare, but can happen.

But I don’t know how booting into bootloader can fail apart from trouble with the buttons.
Please make sure to press Volume - even before a reboot or before you start the phone, and keep it pressed until the Fairphone logo shows up.
If that doesn’t help, take off the case from the phone and try again without it.

I tried the same thing a couple of times.
I’m trying to downgrade to Android 6, cause all 3 games i play are not working at all.
I pushed the volume button down and turned the phone on.
The FP logo and ‘‘powered by android’’ appeared.
Connected my phone on my PC, run the flash-for-windows.bat file and it stated: Checksums do not match, try to download the manual update again.
Which i did 2 times, still getting the same messege.