Android 6.0 is now available (Fairphone OS 17.04.8)

I wanted to update my FP2 to 17.04.8. The FP2 was rooted.
EMMC… has unexpected contends
(status 7)
Installation aborted.
Factory reset, wipe cache, installed FP2-gms75-1.12.0-ota.zip
It is working.
Install FP2-gms-17.04.8-ota-from-1.13.0.zip. The same error.
You can clean up the EMMC?
I do not know how to continue.

You have to install 1.13.0 first.

2 Likes

Just upgraded, and now my SD card is corrupted. I tried removing and reinserting, but no luck. It was / is encrypted. Any ideas? I’d rather not reformat if I can avoid.

Related to … ?

I get the exact same error. (Never rooted the phone or tried any other funny things)

Not sure what to do.

Edit/Update: Fourth time is a charm. The update worked. Not sure what I did differently. Everything seems to be fine. Proximity sensor. Apps.

1 Like

Hi,
Thank you for keeping our phones updated!
Just one little issue: I “lost” the SMS/MMS app when I updated to Android 6. Which one was installed before? Android Messages by Google Inc.? Which one would you recommend?

1 Like

I upgraded and now the ‘All apps’ or ‘favorites’ or ‘most used’ or however the widget is called is gone … where do I find that stuff now?

The new default SMS/MMS app on the FP2 is called Android Messages :slight_smile:

2 Likes

A write error. Of course I have the 1.13.0 installed.
The current build number is “r4275.1_FP2_gms76_1.13.0”. Now not rootet.
The same mistake.
Install FP2-gms-17.04.8-ota-from-1.13.0.zip.
EMMC… has unexpected contends
(status 7)
Installation aborted.

1 Like

Yay, worked fine when downloading @home. Installation OK

Thanks!

2 Likes

Upgraded to 2017.04.08 early, last week or so via the then-updated updater from the google play store. Went fine.

Ever since, the google play store app, in settings, shows that the device is of uncertified state or something. Is this to stay? People were talking about it I think hinting that this would become into certified state once the real final release of Android6 was to ship as official upgrade.

Anyone? Thanks.

2 Likes

Hi. Your system partition is probably still altered - it doesn’t matter if it’s rooted or not. Any modification to the system partition will make the update fail.

In this scenario we recommend you to flash 1.13.0 with the manual image and try again.

2 Likes

The update is official and certified by Google, otherwise we are not allowed to release it to the public :wink:

About the ‘state’ in the Play Store, this might take some time to be updated from their side. The Play Store only checks the state after an update to their services (these are done in the background). So in the next Play Store update you will see the ‘Certified’ label.

To ‘force’ this already, simply delete the Play Store app data. After that it will show:

Edit: added more info + screenshot.

5 Likes

Fortunately, when I put the sdcard in another device it was not corrupted, and on putting it back in the phone I am now able to read it. so I think just a reseating of the card is enough.

Now to look at the problem with apps on the card.

Updated today without any problems (encrypted, unrooted FP2).
It’s very good though, the installer takes notice of a disabled google-app. I wasn’t aware I had disabled it in the past! Thank you for that.
To disable it again after the update follow this wiki:


(And as I understand be aware to enable the app again before the next update…)
Thanks to the community for the great support!
Cheers
Alex

2 Likes

After the marshmallow update my phone won’t detect my sim cards. Both sims were fine before the update and now even after removing and reinserting them, they aren’t detected. The top of the screen says “no sim card” and under Settings>SIM Cards, it says “SIM empty”. I’ve switched off and on again several times.

It seems too much of a coincidence for both SIMs to be damaged, unless it was the update that fried them, so hoping it can be fixed under Settings somehow.

Update: Put a new sim in slot 1 and now both slots are detected. Don’t know what happened there but all working fine now

You don’t have to enable it again, just do the following and you’ll never have to bother with the G App again:

2 Likes

No clues yet? Tried it several times today (even re-installed the old firmware just in case). That didn’t help. This really is annoying as I never did anything different than use the regular Updater by Fairphone.
Will make a regular call, but hope someone from fairphone will respond on the forum. I feel left in the dark (and this isn’t the first time this happens… :frowning:)

Hi @Led71. If you get the error “unexpected content” that means your system partition is altered. Same issue as mentioned before.

That may be the case, but i never rooted the phone. I did try the solution mentioned above, but that also didn’t work.