Android 6.0 is now available (Fairphone OS 17.04.8)

OK, I finally managed to get it right… First I downloaded the 1.13.0 update file, copied to the phone and installed it by opening it with the Updater via Amaze. That effectively de-rooted the phone (I think the previous time, I just restored the boot loader but not the OS itself).

After reinstalling 1.13.0 I was able to install 17.04.8 seamlessly… Thanks a lot to the Fairphone team for the great work you are doing!


Ah yes, thanks. And of course it now also appears when you pull down the settings even in the locked screen (which wasn’t the case before). Will take getting used to, but I think it’ll work :slight_smile:


Yes, three times in fact. Also did the disassembling and cleaning routine. I read at least one other user reporting this in the forum, so chances are it’s connected to the update. I was about to open a ticket, but I’m willing to wait a bit for news from the forum if that helps you - I guess support will have plenty to do after such an upgrade :wink:


Here it is stated:

1 Like

I was one who received the update accidentally last week and I did not receive a new one today (the version number also stayed the same).

Now my Google Play Store still states that my device status is not certified.

When and how will this change back to a certified device?



Hi all,

i gave up, it seems to be impossible to update my Phone. Tried it several times (normal Mode, Advanced Mode, Manuel Install) and always get the same error. When Rebooting i got d dead Android with error
system partition has unexpected contents
Error in /cache/ (when i try manual update), in normal Mode its a different file. Phone Memory still has 42% free space.
Never had any trouble updating (once i need Advanced Mode).
I’ve got one of the First 17000 so i started with initial Firmware and made all Updates till the latest one. Never Rooted nor other “special” Programs :cry:


The update worked fine. But when having a phone call the display goes black and doesn’t react to anything. The phone call itself works fine. Recalibrating the proximity sensor doesn’t change anything.

Just forgot:
Error is 7. But Phone was never rooted!

Unfortunately I can’t install the update because the signature verification repeatedly fails.


  1. The download works fine, I have >7GB free internal storage
  2. The updater asks to reboot
  3. after reboot I end up on the Android system recovery screen where it says:

Finding update package…
Opening update package…
Verifying update package…
E: footer is wrong
E: signature verification failed
Installation aborted.

I can then select whether I want to reboot, apply the update from ADB or SD card, wipe the phone etc.
If I reboot I return to the existing Android 5 version, which is working without any problem.

Is there any solution for this? Am I doing anything wrong?

Have you tried to reinstall the version you are currently running (to be really sure system partition is unchanged) and try the update then?

How about any cleanup after the update? Are there any leftovers from Lollipop wasting space or will everything be cleaned ready to use?
Has anyone checked on this?

1 Like

Dear ANeuzy,

I’m having the same problem. Have you found a solution already?

Android 6 wasn´t available when FP2 was in the final development state. Now FP have used free resources to catch up with Marshmallow growing the market while Google pumps out Nougat and Oreo (Android 8 actually is only available for G**gle devices (
This is simply a too fast pace for a startup as FP to keep up with, but also many other manufacturers are under heavy-duty bringing Nougat onto their devices.
Let alone that a more state-of-the-art OS might will not fulfill anyones user expectations on the existing FP2 hardware, maybe it would not even work on older hardware (for the lack of drivers, licenses etc.).

So maybe no step inbetween but the last step for the available FP2 hardware setup.

Same problems here. I tried to install the update with the automatic updater and manually, but both methods fail. I have the most recent firmware and never rooted my phone. Cleared the cache and tried several installs, no succes. All end with the dead Android sign and message something like “unexpected content”.
Anyone got any good ideas?

many thanks, your hint to install the current Version fixed the Problem. After manual install of the last Android 5.1 Firmware (File-Download Fairphone OS 1.13.0 on FP2 and opening with Updater) i could sucessfully update to Android 6.0. No clue why it didn’t work before.
First check everything works fine, no proximity Sensor Bug.
Missing my “most called Persons” widget :cry:. But maybe its coming back.

Thanks again


1 Like

I’m very happy: Approx 200+ Apps were migrated successfully automagically via OTA update from 1.13 to official Android 6 17.04.8 (I’ve put the phone into the fridge during “optimizing” process :slight_smile: Thank you very much!


I’ve updated successfully and so far very happy - my FP2 seems much more responsive! Thanks FairPhone! I have noticed an issue with WhatsApp though - all my old images are blurry, from reading a bit it sounds like the app thinks I’ve removed the SD card (but I haven’t, I selected the option to use it as an external device so that it wouldn’t get formatted). Any ideas?

Updated without any problem. :+1:


I have found that you need to give Whatsapp permission to access storage. Then all my images/photos loaded up in high quality again. (Settings/apps/Whatsapp).

1 Like

Giving WhatsApp storage permissions solved it, thanks!