English

Android 6.0 is now available (Fairphone OS 17.04.8)

I had the same experience, just be patient. I was going to post about it here as well but as I was writing it suddenly the update appeared on my FP :wink:

3 Likes

“Error in the Heading section” or something like that?
Shell I try again?

Thanks a lot for your kind help Paul. What I did to unroot was precisely that, however I’m willing to try it again but in the Updater’s Advanced Mode I just see one entry for 17.04.8, and nothing for 1.13.0

One question, if I follow the full update procedure whenever the binary file is available, I will lose my user data, or it is safe on this regard?

Full update and binary are two different things.
With the full update, I’ve done all the updates over the last past months and never lost anything.

That’s what I’d do. Was it maybe “footer is wrong”? That sometimes happens if something went wrong during the download of the file.

Oh sorry. You could try a manual "up"date, but I can’t find the page with the files on the support pages atm, they seem to get revamped right now.

I don’t know what yo mean by that exactly, but usually updating doesn’t erase any data unless you switch between FP OS and Open OS.

Loving the new startup animation and “Change is in your hands”!! :smiley:

6 Likes

Yay, no more “peace of mind”. Apparently I suck at being peaceful, but that widget really got on my nerves. The lock screen with the plain old clock is excellent for me.

9 Likes

Did the update just now. Except draining the battery down to 0% it worked as smooth as can be. All apps I have tried so far are functioning, the home-screen has been migrated nicely, and all accounts I have tried still connect perfectly. Good job!

The only serious problem I have is that the proximity sensor issue is back!

4 Likes

Happy to hear the update went well! About your Proximity Sensor issue; have you tried recalibrating it again? (System Settings -> Maintenance)

A post was split to a new topic: Android 6 Upgrade bleibt stecken “Ausschalten, wird heruntergefahren”

Failure again :frowning:
After “verifying update package…” :
E: footer is wrong
E: signature verification failed
installation aborted

I will try again at home, with better internet connection (low wi-fi here)

Another happy user here! Upgrade went flawless this morning, and I’m very pleased with the per-app permission settings added in Android 6.

4 Likes

Hey Rick

Will/can you make a bug thread for the new update/6.0?
Or would you guys perfer if just post in https://forum.fairphone.com/c/19-fairphone2help?

Thanks, I was referring to the procedure described in the “4. Flash the binary images from a computer” of the manual update page (you are right, they were updating it and now we all can access to the 17.04.8 files, this morning only 1.13.0 there).

In that section it describes how to install the full 17.04.8 package, via fastboot, instead of the delta from the 1.13.0. A bit unusure if that will flatten the phone to a factory installation…

Sorry! I just reread the article and it says clearly “The user data will be erased”… so I’m not in doubt anymore :slight_smile:

The update worked perfectly for me. Good job, thanks@everybody involved!

4 Likes

Sad that it’s gone, it was an important feature for me :frowning:

So far looking good! However already noticed two things that I’m sorry are gone. The ‘peace of mind’ feature (as I mention elsewhere), and the option to put the phone on complete silence (including no vibration, ie - ‘do not disturb’) from the locked screen. Correct me if I’m wrong, but now to be able to put the phone on do not disturb, you have to unlock the phone, pull down the setting menu, and tap it from there. Not the best process when you need to silence your phone quickly…

Press and hold the volume down button :slight_smile:

5 Likes

It might just be an illusion but I feel the lockscreen and scrolling to be much smoother after the update than before. Anyone else?

2 Likes