Android 6.0 is now available (Fairphone OS 17.04.8)

Yay, worked fine when downloading @home. Installation OK

Thanks!

2 Likes

Upgraded to 2017.04.08 early, last week or so via the then-updated updater from the google play store. Went fine.

Ever since, the google play store app, in settings, shows that the device is of uncertified state or something. Is this to stay? People were talking about it I think hinting that this would become into certified state once the real final release of Android6 was to ship as official upgrade.

Anyone? Thanks.

2 Likes

Hi. Your system partition is probably still altered - it doesn’t matter if it’s rooted or not. Any modification to the system partition will make the update fail.

In this scenario we recommend you to flash 1.13.0 with the manual image and try again.

2 Likes

The update is official and certified by Google, otherwise we are not allowed to release it to the public :wink:

About the ‘state’ in the Play Store, this might take some time to be updated from their side. The Play Store only checks the state after an update to their services (these are done in the background). So in the next Play Store update you will see the ‘Certified’ label.

To ‘force’ this already, simply delete the Play Store app data. After that it will show:

Edit: added more info + screenshot.

5 Likes

Fortunately, when I put the sdcard in another device it was not corrupted, and on putting it back in the phone I am now able to read it. so I think just a reseating of the card is enough.

Now to look at the problem with apps on the card.

Updated today without any problems (encrypted, unrooted FP2).
It’s very good though, the installer takes notice of a disabled google-app. I wasn’t aware I had disabled it in the past! Thank you for that.
To disable it again after the update follow this wiki:


(And as I understand be aware to enable the app again before the next update…)
Thanks to the community for the great support!
Cheers
Alex

2 Likes

After the marshmallow update my phone won’t detect my sim cards. Both sims were fine before the update and now even after removing and reinserting them, they aren’t detected. The top of the screen says “no sim card” and under Settings>SIM Cards, it says “SIM empty”. I’ve switched off and on again several times.

It seems too much of a coincidence for both SIMs to be damaged, unless it was the update that fried them, so hoping it can be fixed under Settings somehow.

Update: Put a new sim in slot 1 and now both slots are detected. Don’t know what happened there but all working fine now

You don’t have to enable it again, just do the following and you’ll never have to bother with the G App again:

2 Likes

No clues yet? Tried it several times today (even re-installed the old firmware just in case). That didn’t help. This really is annoying as I never did anything different than use the regular Updater by Fairphone.
Will make a regular call, but hope someone from fairphone will respond on the forum. I feel left in the dark (and this isn’t the first time this happens… :frowning:)

Hi @Led71. If you get the error “unexpected content” that means your system partition is altered. Same issue as mentioned before.

That may be the case, but i never rooted the phone. I did try the solution mentioned above, but that also didn’t work.

I have the same “signature verification failed” problem, I tried 3 times… anyone has a suggestion?

As far as I can tell, the update works on Sim 1 but I keep getting an error message on Sim 2. It keeps telling me the process android.process.media (?) has stopped. Has anyone else encountered this?

Also, I can’t find Amaze anymore? What happened to those files and folders?

Even better! Thanks!

All works fine here, upgrade went smooth and tested Android Auto; it works better and more stable than with Android 5. I like Android 6 with the detailed possibilities to select the rights for apps. The phone feels somewhat snappier and indeed battery consumption seems to be improved. Good job!

2 Likes

I’ve downloaded twice and keep getting the same error message on re-start. Screen is stuck on the android robot with error message: Android system recovery (3e) r4275. 1_FP2_gms65_1.7.0 gives me the options to: reboot system now, apply updated from ADB, wipe data/factory reset, wipe cache partition, reboot to bootloader, power down, view recovery logs, apply update from SD card. What do I do?

I did the upgrade yesterday (from Patagonia!!!) with version 17.04.8 from Android 5.1: everything worked fine as described in the procedure.
I feel FP2 faster and more stable, however it needs some week of running to judge it.
No issues with battery, power consumption as usual.

Regards

2 Likes

My proximity sensor also doesn’t work even after recalibrating. It still worked in 17.04.3.

[If I only missed the right post feel free to point me to]

In reference to this wiki-post about updating with TWRP at a rooted phone I asked myself and could not find an answer until now:

Do we know already if and how the wiki post about the TWRP-Update-Procedure needs to be changed in order to update from Android 5.1 (1.13.0 or even <1.13.0) to FPOS to Android 6 / FPOS 17.04.8 via TWRP on a rooted phone?

Please note: Manually updating to Android 6.0 with the update file below can only be done on a Fairphone 2 device running Fairphone OS 1.13.0 (our latest version for Android 5.1). [LINK]

Maybe author of the wiki @danielsjohan can help out?

As far as I understand, the upgrading procedure is described here.
I couldn’t test it yet, but I will probably just switch to FP Open to avoid these issues in the future :slight_smile: