Android 6.0 is now available (Fairphone OS 17.04.8)

Hi Rick,

I never rooted the phone, so I am curious why my Phone has a boot, system or recovery partition modified.

I always have used the updater to install new firmware. One time it didn’t work automatically, i had to download the bin on my phone and install it with the updater. I never used the ADB method.



Hi Dennis. Updating through the Updater app is something different than flashing a device. The bin you mentioned is not the image file, but the OTA (over-the-air) .zip file. This procedure won’t solve your issue; it’s basically the same as downloading the update through the Updater app, but now you just load it in manually.

Altering the partition is also possible by using a different recovery in the past - not rooting the device is not always the only reason why it doesn’t work. Have you modified anything in the past? Like using a different recovery?

In short; to solve the issue with your phone you need to flash it with the binary image file provided on the download page. I’ve read you already contacted my colleague Gabriele, he can assist you further :slight_smile: And yes, a factory reset will solve the issue, but try to use that as a last resort.

The “reboot” and “airplane mode” option are gone from the power off menu. Is there another way to reboot the phone?

1 Like

I made an opposite experience this weekend! :unamused:
While driving, the Phone lost very frequently the Signal, leading to wrong indications or none at all. sometimes it was lost for a short time (< 1min) sometimes I had to close and reopen the navigation App to resolve the problem … Not what someone should to while driving
I uninstalled the App “GPS Status & Toolbox” which never made any troubles but as it is active in the background when GPS is connected, I thought it would help. First it seemed to work better, but then the signal was lost again… :disappointed:
I used alternately TomTom Go and Google Maps (Android Auto). TomTom seemed to work better.

I don’t know if this is related with Android 6, but I never had these troubles with Android 5. GPS is very important for me, I don’t use it every day, but it should be reliable and work when it is needed!

Airplane mode can be accessed from the swipe down menu. Reboot (for the moment) only by turning the phone off and on again …

No you didn’t! :wink: @WoBoW was takling about this issue, which you clearly don’t have.
For general GPS troubles check out the gpsguide.

OK you got me :wink: I have got a different problem. But my experience WAS the opposite as it was not “finally GPS works flawless” but “I can’t rely on my phone’s GPS any more”.
I will try with a data cable, as this sounds legit because of better shielding. But I still think it’s related to the Update as nothing else had been changed.

1 Like

Any idea how is that so?

This is one of the customisations Fairphone made to Android 5. Android 6 is pretty much the stock Android.
They omitted those modifiactions as you can read here: Android 6.0 coming to the Fairphone 2 - Fairphone

By taking a more standardized approach, we can free up some of our limited time and resources to focus on other projects…

Time will show if some of the custom features will come back in near future. There are developers in the community willing to do this and publish things like the Edge Swipe Menu or the Widgets on Fdroid. But I guess modifications to the Shutdown Menu will need more than just a third party App …

1 Like

So after a couple of weeks of things running pretty smoothly, the phone started to reboot itself for no good reason again, like it did before the upgrade (not quite as often yet, but the trend is not good…) :frowning:

Dear all,

After I did a factory reset (bootloop due to google app) I got an issue with battery drain. According to the battery monitor WiFi is the reason. I searched and found it was a common problem with marshmallow. I tried all solutions that were recommended (network reset, WiFi settings and location settings) without success. What would you recommend: factory reset or re-install with updater experienced mode?? Are all my data wiped with the updater solution?

Thanks for your help!!

Good things first: I found that while unwanted resets still happen every now and then freezes have become less - but that’s just a first impressions from a few weeks of usage now.

What annoys me most is that my Network based location handling with Tasker is not to working anymore - I only get a Network location update on reboot. To fix it I had to switch to Network + GPS location which obviously will leech the battery more.
I found a similar claim regarding CM13 where it was narrowed down to a ROM issue - thus not sure if it’s a ROM issue on FP2 as well or if Tasker is not up-to-date with latest location handling…

Finally found some time this bright Sunday afternoon to update my FP2 to MM.

Since I had deactivated multiple system apps including Google App I made a backup first using TWRP without installation like described by @retsifp (using the signed TWRP image provided by @z3ntu).

Then I reactivated the Google App (as mentioned in post #2) to avoid the bootloop problem and updated it to the current release.
This, however, did only help partially: the FP2 wasn’t caught in the bootloop but the update canceled with the same error message @fj40heinz mentioned in post #55. So I reactivated all deactivated system apps again and updated them to the current version, which didn’t help either.
The solution was to reinstall FP OS version 1.13.0 again (OTA file via Updater) like suggested by @ChuckMorris and @anon12454812.

After that the update to 17.04.8 went smoothly. Next step will be to make another TWRP to be on the safe side.
So thanks to all of you (and - not to forget - to @paulakreuzer) for providing your insights and solutions for the issues related to MM update here in the forum. You all really saved my day!
Special thanks go to the guys at Fairphone for providing the Android 6 update in the first place.


WOW! After I updated it seems that the screen cannot rotate anymore. Anyone else having this problem? It is both when I turn on the automatic totate-thing as well as when I take photographs. And that means that now I cannnot take horizontal pictures :confused:

I can’t rotate the screen when on the homescreen, but that wasn’t possible with 5.1 either.
But it’s working flawlessly with the apps I tested (Open Camera, stock Contacts app, stock Telephone app).

I had no problem rotating my screen before the update to Android 6. Now I cannot rotate anywhere.

Maybe a stupid question, but anyway: are you sure you haven’t accidentially switched of autorotate?
You can check in the swipe-down menu or under Settings - Display - When device is rotated (should be “Rotate the contents of the screen”).

1 Like

Yes, I am very sure :slight_smile: I have tried that - it makes no difference. Also this shouldn’t have any effect when I try to take a horizontal photograph. The camera should always automatically register if the phone is put to horizontal and adjust the photo to that no matter what is turned on or off in the swipe-down menu.

Ok… now it suddenly works out from nowhere. Hope it will keep working :slight_smile:

Same here. But all in all the Update worked Out pretty Well.
Only new issue I got, i cant Charge my Phone from my PC even if it Shows "USB Connection Charge only"