English

Android 6.0 is now available (Fairphone OS 17.04.8)

The Updater tells me FP is updated, but it still has Android 5 (Fairphone OS 1.13.0). Is it normal? I’m really looking forward to get it…!

Have you updated the app with the Playstore?

3 Likes

That was it lol.

Thanks Peter974

2 Likes

My early-by-a-surfeit-of-enthusiasm Marshmallow FP2 also shows as uncertified.

Not a thing I’ve ever done, so I explored and tried this method.

  1. Settings -> Apps -> Google Play Store -> Force Stop -> OK
  2. Launch Play Store -> Settings -> Scroll down
    And it still shows uncertified, so I guess that’s not how I “simply delete the Play Store app data.”

Posting in case anyone else is equally bemused, and in hope of a more experienced user telling us the simple way to delete Play Store app data! :wink:

Edit: solved

Just below the the ‘disable’ and ‘force stop’ buttons, there’s an item called ‘storage’. If you tap that, you should get the options relating to wiping data (clear data should also wipe cache).

1 Like

Thank you! A tappable storage option wasn’t showing (I looked for it), but I got there by this route:

  1. Settings -> Storage & USB -> Internal storage -> Apps -> Sort by name -> Google Play Store -> Clear Data
  2. Launch Play Store -> Settings -> Scroll down

Success! :+1:

2 Likes

After update to 6.0, my battery is draining very fast again. Battery lasts for 5 hours or so, when I dont’ t use the phone. Phone tells me that the Wifi-connection uses much of battery - even when the connection is disabled - HAHAHA! after years of troubleshooting, replacing a few times, I finally had a phone that worked more or less. Now back to starting point! making a failphone even worse - that was not easy, i think! probably just one update more to crash it completely…

I updated smoothly to Android 6. However, I discovered a little bug: The message that we can display on the locked home window is very limited in size. Thus, my address is not fully displayed :frowning: Is there a place to report bugs efficiently ?!?

Great to finally get the update, fantastic work! Two main issues in my case so far:

  • The flicker-on-scroll problem after reboot still occurs. (So hardware / driver problem?) Luckily the flickering still disappears after a short time.

  • The automatic time & date setting doesn’t work as expected. Well, the automatic update pulls down the right date/time which can be seen on the setting page. However, it seems it doesn’t update the phone properly. It was off by about 20 minutes. I had to turn off automatic updates, set the time manually once, and now turned it back on. But now I don’t really trust it to keep updating automatically… Will do more tests when I have time (!) for it.

Kim

This has been reported here.

Thanks a million, I have voted now :wink:

Same problem! Also tried to clean and recalibrate it several times but it didnt solve it! Must be a software thing!

After a few days of use I noticed that the battery life is back to the level when I bought the device (that is, about a day and a half). The AccuBattery app suspects the quality of my battery is roughly 80-90% ( :frowning: ), which implies that Android 5.1 got more and more power hungry over time. Of course I don’t know whether that was due to the apps I chose to run in the background or more fundamental problems with the 5.1 FPOS, but either way happy that my battery lasts better now.

One thing I did notice is that the Android 6 build still ships with kernel 3.4. Although important security fixes appear to be backported, this implies that all the upstream improvements made in the past 5 years by the Linaro team have not made it to my phone. Although I’m not holding my breath that the kernel used for FPOS can be rebased to upstream as driver porting would become a nightmare, I wonder if there’s plans in the pipeline to rebase to one of the 3.10, 3.18 or 4.4 msm kernels available for Android?

Still no usefull solution, so I have another question: would it help if i did a factory reset of the phone? I don’t like doing that, but i really have no idea to solve the problems with the update.

1 Like

Hello,

I have just updated tonight to Android 6. It was very smoothly - it worked like the security patches on Android 5.

It seems I was one of the lucky ones. Thanks a lot to the Fairphone Team.

Regards,
Thomas

1 Like

Smooth update, I also prefer the simpler home and lock screens. Thanks!

3 Likes

Updated yesterday a little nervously​ but encouraged by forum reports of it going well for people. I had no problems. All seems fine so far. Good work team and thanks​! I’m posting to encourage others. We don’t want only the bad news here.

All that said, my phone is only 2 weeks old, has stacks of free memory, hasn’t been rooted and I haven’t deleted any Google apps so it should be about as straightforward as it gets.

3 Likes

Same question from me. I received a mail from fairphone that took me to the google play store, but when I press install button nothing happens at all. (JFYI I do not have a google account, and I do not want one, don’t ask me why.) Would it be possible to get the updater from the F-Doid store as well? Thank you so much.

1 Like

You can use the Yalp Store to download all free (as in free beer) apps from the Play Store. It is available on F-Droid.

3 Likes

Phone works like a charm after the upgrade. Good work!

2 Likes