Android 6.0 and hot backside FP2

I installed Android 6.0 this week, but now my FP2 is getting hot on the backside of the phone.

Also is the battery empty in 3 hours…
Anyone the same experience?

Peter van der Zijde


Only right after the update upgrade process and the first minutes therafter reboot. Everything should be back to idle normal and cool again shortly after that.

Maybe shutdown your phone completely for a while and boot it back up then again.

Same issue, after updating with Android 6, 4 days ago, suddenly, the FP2, gets super hots, and the battery drains at the speed of light. Even when being plugged in, it charges very slowly, and actually not enough to charge it.
-I took the battery off for 30/40mn - Does not solve the problem
-Rebooted the phone= still the same issue (-Issue is likely to be with CPU, not the battery)
-Updated the phone Fairphone software - still unsolved
-Formatted the SD card, as i was force to do so after installing Android 6, and also read in this forum that this could cause the problem, but still same problem.
Any solution, suggestion from support?


I have exactly the same problem as coucou46.

Have a look at the battery statistics which app(s) use the high amount of battery. In my case I had to reestablish my POP3 and exchange accounts by completely removing them and deleting the associated apps data and cache. Perhaps there are other apps which you can try to remove for testing. Also check under settings - display how much time is set for stand by mode (but that should not be a reason for the hot backside).


The problem still insists.
With the phone operating the battery takes hours to fully charge. Using any kind of app during battery charge, prolongs the duration of charging (some times even reduces the percentage of charging level despite being plugged).
With the phone off the battery charges normally.

What I did so far:

Since my companion has the same phone, we exchanged batteries in case mine was malfunctioning. It did not. In her phone my battery worked fine, and her battery in my device started discharging rapidly.

I took off both sim cards and a memory card. The phone still behaved abnormally (discharging rapidly).

I exchanged sim cards with my companion. When we put my sim in her device, it appeared to increase the discharging rate of her battery. At the same time, my device with her sim in it kept behaving abnormally (discharging rapidly). This doesn’t make any sense: is the problem with my sim card or with my device?

I uninstalled every app that I installed during the last few weeks (just before this behaviour appears), but to no avail. I even uninstall several apps which I had for months before all this (I reinstall them afterwards since I need them).

I deleted the cache memory of every app (nothing changed).

I keep the screen lighting to the lowest level (off). It doesn’t help.

In general:
The battery (after it is fully charged) lasts for less than 90 mins.
The battery takes a huge amount of time to fully charge when the device is on.
The battery charges normally when the device is off.
All the above whether I keep my sim in the device or not.

Other odd symptoms:
There seems to be a delay in receiving text messages (SMS). It might just be the mobile company I use, it might be the messaging app (which I cannot uninstall).
Some app notifications (twitter and chrome) don’t open the app when I press on them. Instead the notification fades off, but the app doesn’t starts (the notification is still visible in the slide-down menu).

Following are a few screenshots:

The battery needs 24 hours until fully charged.

The screen usage at the same time with the above screenshot.

Below are four consecutive screenshots. The battery percentage decreases from 29% to 17% in less than two minutes!

I would appreciate any help.

Thanks in advance.


This sound like there’s something using all available cpu resources. I’d install cpu-z and have a look at cpu load.

1 Like

Thanks for your help!

I just installed cpu-z and it shows 60%-80% and often it reaches levels above 90%.

I presume this is not normal or good. The question is what can I do to find the culprit?

Probably this is not good and normal. My phone shows <30% most of the time and very often 2 cpus stopped (or at 300 MHz).
You may try “usage timelines free” to monitor processes.

1 Like

Mine shows all four CPUs working at 2265MHz most of the time (occasionally one will be stopped or will show a smaller frequency) and the CPU load doesn’t go below 60%.

I’ll install Usage Timelines Free and will report results here ASAP.

These are three screenshots of Usage Timelines Free.

I have no idea what these 28445 permission denials are.

I suppose you’ve “unchecked” “Hide System Processes”. If I show those system processes I get the same “messages” (process ID and “permission denied”). So maybe this app won’t help to find out the “offending process” :frowning:
Maybe someone else knows a better app to show CPU load of all processes (as I’m still convinced that your CPU usage is not “normal”…

If nothing else helps you might still do a full system and data backup, do a factory reset and try to restore apps and data…

1 Like

Thanks for your help anyway!

1 Like

Hi @Stamatis_Stamatopoul! Did you do a factory reset as suggested? What was the outcome? I’m having the exact same problem you’re facing and I’d love to find a solution. The only difference is that cpu-z reports lower levels of activity in my FP2, but the phone is still very hot and the battery drain is intense. Let me know if the reset worked for you. Cheers!

Hi Culilara.

No, I haven’t done a factory reset yet, although that will probably be my next step. Unfortunately I have several things installed in my device that I need to handle first (like Google’s 2FA for several sites). It will take a few days (probably during this weekend if I manage to find the time) before I try it.
I will post here the outcome.

PS. my device is hot because of the CPU overload. The battery’s temperature is in normal levels. Is it the same for you?

Yup, according to cpu-z the battery temperature stays normal, it’s the other parts that overheat.
I understand that it’s a hassle to do the factory reset. This is why I haven’t done it yet in the first place :grinning:, but whenever you get around to it I’d love to read about your outcome. Good luck!

I also had the same problem : overheating for no reason and fast battery drainage after the last update.
I was part of the android 6 beta testers and it didn’t happen when I switched to MM, but really after the last update.
I first tried the battery reset, to no avail.
I then tried CleanMaster to start with and the problem got slightly better, but only slightly as I had enough battery to finish the day wich was not the case before.
I finally did a factory reset yesterday which seems to have solved the problem as the phone seems to be using the battery at a normal rate. For example, I only lost 1% during the night…
So my advice is : if you have the overheating/ battery drainage problem, do a factory reset. It’s a hassle but it really works!

1 Like

The problem seems to be solved by itself. I did the last update a few days ago and since then energy consumption works normal. I didn’t need to do a reset.

Hopefully it won’t reappear.

Thanks in any case for any help and advice.

I have similar problem after update to Fairphone Open 17.06.4. The CPU is hot and battery drain is high only when using some cpu/gpu hungry app. Using same apps before the update did not make the CPU area that hot and battery drain that high. @Stamatis_Stamatopoul what version solved your issue?

1 Like


I tried to upgrade from Fairphone Open 17.04 to 17.06.4 but as I faced this overheating and overdraining issues as well :

  • First thing I did was to execute an OTA upgrade to 17.06.4. After this I noticed the battery was loosing approx 1% per minute and that the back was very very hot. Leaving the phone idle didn’t help, the battery was still draining and the phone case was still hot. When connected at the USB power supply, the phone didn’t even charge.
  • Rebooting the phone didn’t change anything.
  • I disabled wifi during sleep as advised by the pouplar “How to fix Android Marshmallow Wifi Battery Drain” article, but this did not help. However I was not able to disable wifi scanning as I didn’t find the mentionned menu in the location section.
  • I did a factory reset to start again from a clean state, unfortunately this did not help either.

I didn’t know what to try next so I stepped back to 17.04.

I’m very disappointed about this issue as it prevent me from using the newer release.