Android 12 has come to the FP4

My operators are Congstar(:de:) and Proximus(:belgium:) with Proximus providing the data right now. The update has been offered to me within days after the release. After ignoring the update for that long because of all the issues reported here, I finally installed it today. :see_no_evil:
My conclusion so far: The UI overhaul looks horrible to me, but I’ll get used to it, I suppose. But functionally everything I have used so far seems to work as expected. :crossed_fingers:


Same here. Same location and provider and waiting as well… :face_with_diagonal_mouth:

Fellow KPN user here and no A12 update yet. The latest security update was pushed but for now we must wait for the A12 update as said earlier in the thread. Let’s hope it comes soon for us. :slight_smile:

Is there any information on when the next update of A12 on FP4 will be available and if it will fix the Bluetooth/AptX and hotspot problems?

No there are no details published yet. My personal guess would be: this month.

1 Like

I’ll do you one better, it’s today :tada:


That’s good news! Thanks for the update.

A post was merged into an existing topic: Software update: FP4.SP21.B.048.20230215

News from Switzerland: Swisscom users getting Android 12 for their Fairphone 4 now, too (at least I did today).
[edit] I’ve been asked to move my post to the new thread, titled “FP4.SP21.B.048.20230215”. But after some consideration I’m gonna leave this part of my post here, because users who are scanning this thread for “Android 12” and “Swisscom” might miss the other thread. For further discussion about that update (which indeed is Android 12), please refer to this thread: Software update: FP4.SP21.B.048.20230215


There is a new thread for the latest release

So if that is what you have please continue there. You can delete this post and create it there :slight_smile:

Android 12 genuinely sucks. I payed almost 800 EUR to buy a Fairphone 4, that I can’t properly use anymore.
On android 11 the lock screen clock was ledgible, now I genuinely CAN’T READ IT. I feel like I am dyslexic (I’m not), I can’t read anything properly anymore. Using the Phone now feels like you’re drunk and are trying to call a taxi, everything is squishy and slippery.
At least the animations can be turned of in accessibility settings (The whole phone gets much faster and snapper that way).
You’d expect a new update to have more customizability to allow people with special needs to get some accessibility. Oh wait, more customizability is what the update was SUPPOSED TO CONTAIN.
Though, most of the features, that were included in the update were done nice, especially the privacy changes.

Could you please explain more detailed, why you can‘t read the clock? It‘s bigger now, not very cute in my opinion, but it should be easier to read, without glasses or from the distance for example.

Just a note about the lock screen clock. Standard FPOS FP4.SP1Y.B.041.20230109 (yes I know about the new version, am just about to udate …), standard launcher.

I noticed that, having added a widget from the standard Clock app to the home screen, it is used also on the lock screen, except for the short time after a reboot before unlocking the phone for the first time (Edit: there seems to be a link with the At a Glance preferences too). So my Home screen and Lock screen are quite enviable (Google thing reduced to a strict minimum too!)

Sorry if this has already been noted elsewhere or general knowledge.

EDIT: after updating to SP21.B.048.20230215 the search tool is back instead of “At a glance”, :frowning:

but the lock screen clock’s still OK :slightly_smiling_face:

A post was merged into an existing topic: Software update: FP4.SP21.B.048.20230215

I have not the slightest Idea why, but when the clock is stacked in two rows, It is simply hard to read and requires active effort to read correctly. At a glance it’s 60:03, but that’s not the right time, it’s 06:30. The clock is big, and easier to make out the numbers, however it is now harder to read and understand.

Also, why is the date at the old area on the screen, and the clock on the new area at the screen?


The upgrade to Android 12 has broken two major features of the FP4 - AptX support and the WLAN hotspot. I was counting on the currrent B.048 update, which is however just disappointing.

  • hotspot still doesn’t work
  • the AptX bug is claimed to be fixed, but it is not for AptX and ApxtX adaptive. Only AptX HD (reportedly) works now.

I’d wish Fairphone did proper and throrough testing before releasing new OS versions :frowning:

1 Like

Hotspot works for me. Did you try to select 2,4GHz channel ?

1 Like

Picking up on power consumption, I note a clear diminution especially when the phone is inactive (but not turned off). At night if I forget to switch on Airplane mode, consumption seems hardly (~ 2-3%) more than with it on ~ 1%). I could probably now go for four days on a full charge, but I usually keep to the 20% - 80% recommended range or narrower, so I just top up every other day or so. I seem to remember reading somewhere that this improvement was expected, but that doesn’t make it any less welcome!

Obviously power usage with the screen on is going to remain unchanged.

Good job :+1:

Yes, I did. Also tried all link encryption settings etc.

Check your APN settings > APN type. The list needs to contain “dun”. If not present, try to add it.

If adding is refused, in the first place you should contact the network operator.