English

Alternative Apps(tores): Living without Google (FP1)

livingwogoogle
f-droid
Tags: #<Tag:0x00007fefbc776b50> #<Tag:0x00007fefbc776a10>

#181

For the friends of the two-factor-authentication, there is the OTP Authenticator (F-Droid), which - if need be - is also compatible with the “Google Authenticator” (Wikipedia).


#182

I’m trying to set up DavDroid on my father’s FP1. F-Droid won’t let me install. I guess it is the Android version. Can I install an older version? Where would I get that?
Ist there another open app to sync with iCloud?


#183

Minimal SDK version (= Android version) for DAVdroid is 14, which corresponds to Android 4.0.1 Ice Cream Sandwich. So it’s not the Android version, should be another thing.

(If it’s F-Droid what you are trying to install, F-Droid itself shows “2.3.3 or greater” compatibility)

What says the error message?


#184

He has Android 4.2.2 and everything up to date (according to the updater) and no Google installed. If I look for DavDroid - I don’t see the correct icon, just a grey F-Droid icon.


After pressing install - I get the “Nicht Installiert” info. That’s all.


#185

:confused:

Has F-Droid internet connection? Can you download any other app or update repos?

Edit: yes, your repos are not up-to-date since April (1.0.8 version is from April 2016). Last DAVdroid version is 1.3.1-ose

Also, reinstall F-Droid from the webpage, maybe the installed version is an alpha one and it’s full of bugs (I’ve suffered that, non-stable F-Droid versions are really unstable)


#186

Hi, I installed the latest F-Droid .apk - no difference. So I downloaded the DavDroid.apk to my computer and installed it manually. Worked fine. Thanks for the help.


#187

There’s something odd with your F-Droid app… Happy you solved it manually, but I’m afraid your father will not receive updates… :confused:


#188

Same issue here, though I can install other Apps… Should we start another thread for other visitors to see?


#189

Press the three-dotted icon in the top right corner on F-Droids main screen. Then tap “Repositories”. Make sure “F-Droid” is enabled and not just “F-Droid Archive”. Then press the circular arrow icon to reload repositories.
Then you should have RadioDroid 0.24 displayed as the newest version.


#190

Worked like a charm, thanks!


#191

I would suggest to close F-Droid, and wipe all of its application data - this should bring it back to “stock”.


#193

While browsing F-Droid, I came across Yalp Store. Has anyobdy tried this yet? It would save me using raccoon on the Laptop and transferring my files. I haven’t tried it myself.


GPS doesn´t work on FP Open OS
#194

Works like a charm. Just don’t forget to clean your Downloads folder of APKs after each use.


#195

Works wonderful. I can download all the apps in google store without installing the whole google mess.

Of course you need and google account to be able to download the apks, but you can create a fake google account…


#196

Just tried and it works perfectly! Thank you for your suggestion :slight_smile:


#197

When you have UnifiedNIp, yalp says there is an update. If you click on the app to update it, it opens google play services…


#198

There are several UnifiedNIp Versions
GAPPS based, AOSP based (without GAPPS) and Legacy.
Check F-Droid to see, which one you have installed. Because its a system App, you need root to remove it first and than install another version.

Just ignore the update. This is the best.


#199

Yeah, I just wanted to point out the irony, when you install UnifiedNIp without GAPPS to avoid using gms and then Yalp offers gms as an update to UnifiedNIp.
But as you said, I’m not updating this way! F-droid is still my main app store.


#200

I don’t think that would even work. UnifiedNLP is not a real GMS, and Yalp probably would not be able to update UnifiedNLP by the official GMS.


#201

The point here is UnifiedNLP and microG Services Core need to impersonate GMS to be able to replace its services. They share the package ID, which Yalp Store (and F-Droid, and every other store out there) use as an identifier, and as a side effect, confuse it. But if you try to install the “update”, the package installer reports you can’t, because of different package signatures. So no problem, just a little visual issue here, :blush:.

Also remember that Google don’t want us to avoid their services in their walled-garden OS, so microG and UnifiedNLP are working on a limited framework which inevitably causes this kind of issues.

You can read more about this specific problem here:

and about Android’s security model some posts above the quoted before: