All data lost subsequently to a simple power on

Dear Fairphone users,

Last saturday morning, I switched on my Fairphone, as I do every day. Although this time, it booted up to the “first run” configuration screen (the one where you start by choosing your language, see the quick start tutorial, etc.).
I first thought that maybe an OS update had been downloaded and applied. But, once I got out of this first run process, I found myself with a brand new OS, as I would have if I had done a hard reset. Everything had disappeared: apps that I had installed, messages, photos, contacts, … Except I never performed a hard reset (I am not computer-illiterate. I know what I did and did not do)… Besides, the OS is still a Kola Nut 1.8.5, and was not downgraded back to the original 1.7… So, to my understanding, it is not a real hard reset that happened.

Anyhow, here are my questions for you:

  • would any of you know of an explanation for such a behaviour?
  • would you know of any procedure or software that could recover my data (yes, I had no backup… ), as I really need to get it back?

I’ve tried Android Data recovery and Dr. Fone. Nothing worked so far.

Thank you in advance.

Very sorry to hear. Strangly there is another thread here with similar issues: Unprovoked Factory Reset.

Even in a “factory reset” the OS stays at the updated version, as far as i know, as only the data partition are formatted. Are the Google Apps still installed? This could help determine if this was a soft or hard reset.

Anyways, as mentioned in the other thread, to recover some of your deleted data (as long as it is not yet overwritten, you can use PhotoRec or TestDisk (same url). You need to connect your phone in USB mode though for that to work.

Hi Ben,
Thank you for replying to my message.

No, they are not. Pointing out a hard reset?

I’ve been willing to try that, of course. Yet, so far, I can’t make any system mount the FP partition so that I can access it from the command line and execute recovery software (like Scalpel)… Any idea? Tried on Windows 7: partition accessible through Explorer, but no drive letter associated, so not accessible from the DOS command interpreter. Tried on MacOS X, same thing. Tried on Linux (Ubuntu), same problem… Any idea on how to do that?
Thank you for your time.