After rebooting keyboard doesn't load so i can't enter password :(

Hi there!

I received my fairphone yesterday and i’m really enjoying it! the only problem i’m now encountering is that my keyboard doesn’t launch after an reboot and i can’t change the input methode from the lockscreen! i have to hook up an hardware keyboard to type in my password. thats pretty less than ideal! i am using an keyboard from f-droid, hackers keyboard. i have removed/disabled the g-board. does anyone know how to fix this? Thanks for the help!

Do you have a hardware keyboard so you can unlock your phone and e.g. try a different keyboard app or see if hackers keyboard has all necessary permissions?

Yes an hardware keyboard does work! i tried with “simplekeyboard” from f-droid too but it has the same problem sadly :frowning:, i also checked permissions but both keyboards don’t request any. i’ll download some playstore keyboards to see if any of those work better.

I reenabled the google keyboard and that does still allow me to enter the password at boot. weirdly enough though it isn’t even enabled in settings under “manage keyboards”. installing anysoftkeyboard gave an popup message that says “Note: After a reboot, this app can’t start until you unlock your phone” It doesn’t explain why though or how to circumvent that.

It’s reasons like these we need LineageOS support.

1 Like

My quick searching shows this to be a feature of android, not a bug. More likely a bug that they’re keeping around.

I have Gboard disabled and use Swiftkey, I’ve no problems entering a PIN.
Perhaps adoption of a PIN will resolve the issue whilst still allowing the use of a keyboard like Simple or Hacker.

Maybe a keyboard like the AOSP keyboard would work?

i’ll try that one, i doubt it will work since simplekeyboard basically is the AOSP keyboard :wink: but thanks for the info! When i enable it it still says “After a reboot, this app can’t start until you unlock your phone” so i’m afraid that won’t work either :frowning:

ps: just tested it and sadly that one doesn’t work either :frowning: i’m afraid the g-board is mandatory if you want to use an password to unlock.

Sounds like a corrupt SIM. Take the SIM out and do a factory reset with the on/off vol down buttons

I had the same issue. First thing when I tried to setup my brand new FP3 was to install Hackers Keyboard and try to disable the Gboard. But the phone would not let me disable Gboard as an input method (greyed out on the settings screen)
At NetGuard kept alerting me, Gboard makes constant and uneccessary network connections to various google servers, so I tried to disable the Gboard App.

At first this seemed to be working, and I could enter my unlocking password using hackers keyboard.

But after the next hard reboot, I ended up with no working keyboard until after login. I couldn’t login since I didn’t have a USBC OTG adapter for a hardware keyboard so I ended up needing to factory reset and start over.

As a workaround I switched to a locking PIN for the phone instead of a PASSWORD.
PIN entry works using an inbuilt entry method, while PASSWORD uses the active system keyboard. Which ends up NONE when Gboard is not around since Android 9 only activates other keyboard apps after successful login.

This is really annoying, but it seems to be a general Android 9 issue, not a Fairphone specific issue.