After installing 1.8 still 1.6 and hazelnut message

I have a FP from the first batch. I have 1.6 with one partition. Trying to upgrade to 1.8: no error messages, but after restart still 1.6, GoogleApps widget only grey. Withinin Fairphone updater I cleared. Then tried again to update to 1.8. After downloading I choose Install and then get message “error during downloading Hazelnut Fairphone”. Now I have still 1.6 with greys GoogleApps widget. What is going on? Please help.

1 Like

I had almost the same problem, although with the second batch phone. After the update completed nothing would have changed except that all the google apps were gone (no error message for me). I repeated that a couple times but nothing would change.

I finally managed to get the update by downloading the installation file, copying it from the computer to the phone and installing it manually. (Instructions + files) That worked well.

Same problem here. Even downloading 1.6 again and installing it didn’t help with the GoogleApps widget and Kola Nut never really installed (went through the installation process but didn’t see any changes and Fairphone Updater still saying “running 1.6 Cherry”.

Thanks @drat, I’ll give that a try as soon as I find the time :smile:

PS: Just gave it another try the “normal” way via FP-Updater - and it worked… so maybe the updater is simply a bit buggy and we need to try several times? GoogleApps Widget then did not work at first, but as someone else already stated in another thread: open FP-Updater App, close it again and GA-Widget should work, which it luckily did for me.

Same problem. Google services are stopped and return to 1.6.

Hi I have exactly the same problem but I think that installation is in fact incomplete. In my case, inside the update app downloading bar doesn’t change but then I can access “install”. But when I press the install button the android figure appears but no progress of the installation is shown!!! And then my google apps are gone! and I get a can’t install Hazelnut…

I tried everything I found on this site without any success…

Please somebody help!!

AND apparently I can’t do it manually as I have the storage update?!?!

Spent more time on the site and found how to manually install which I did… there

Everything seems to work fine… so far… :wink:

Same here,
After download without a growing progress bar I clicked install and the phone rebooted into the install screen. When finished, still in 1.6, NO Google apps working anymore. Install Google apps widget is gray.
The Updater says there is an update but fails saying it annot download 1.7.

Manual install requires factory reset, I don’t want that :frowning:

Same problem here. I also would like to avoid a factory reset. I just had one for the storage update a few weeks ago.

Isn’t there a nicer solution from fairphone?

I just installed manually… you don’t have to do a factory reset :wink: Go for it!

I can confirm that, I didn’t have to do factory reset for my manual installation and all my data and apps survived.

If you are still running 1.6 could you try opening The Fairphone updater and press the Fairphone OS button.
Next choose Kola Nut 1.8 update.

Done that multiple times doesn’t work… but manual install does!!!


Then I would suggest trying the following (manual updating might be a bit complicated for some :])

First clear the data on the Fairphone updater app.

  • Go to your System Settings
  • Choose the option “apps”
  • Swipe to the tabb called “all”
  • Search for the Fairphone updater and select it
  • Hit “Clear data” and “Force stop” the app

Next you can try to clear the update downloads.

  • Go to your System settings
  • Choose the option “Storage”
  • Choose the option “Downloads”
  • You can select all the “new Fairphone update” files on the left side
  • Tap on the icon at the top right (looks like a trash can)
  • Go back one page and choose the option “Cached data”
  • A “Clear data?” message will pop up, choose OK

Now try doing the update again through the Fairphone Updater app.

Thank you Techaddict. I did everything you described. Unfortunatley, when I want to start an update with the Fairphone Updater now I get the following message:

“You are running
Fairphoen Cherry 1.6
There are no updates avaiable”

Also the Google apps are still gone and can’t be installed again at this time. Also not after clearing the cache of the Fairphone OS.

I might try the manual installation later.

Because so many issues are rising because of the new update Fairphone decided to halt pushing the update for now.
More information about this should follow probably later today.

However you can still do the manual update like you said.

1 Like

This tip (“If you are still running 1.6 could you try opening The Fairphone updater and press the Fairphone OS button.
Next choose Kola Nut 1.8 update.”) works for me. Everything fine now. Thanks.

works for me (post must have 20 characters so now it does)