English

After FP2 Update to 18.04.1: Battery drains very fast

Yesterday the notfifier informed my that there was a new release for my phone. I updated my phone to “fp2-sibon-18.04.1” via the regular updater. The update was successfull but after approximately 4h I heard a ping which told be that I had only 18% battery left. When I started the update it was at 96%.
This morning it was at 100% when I left the house. After 2,5h and Surfing web pages for approximately 30 minutes it was down to 56%.

I didn’t install any new apps (But a few were updated the same day) but i feel the update did no good. The phone also is more than hand warm at the back side (upper area). I rebooted twice but there is no change.

Anyone out there you can verify this?

Thanks,

Michael

1 Like

It was reported many times before that for some time after an update the battery drains fast. If this doesn’t stop soon, then something might have gone wrong with the update, so try to reinstall it.

if you take your battery out, plug in your phone so that it vibrates a few times, unplug it again, re-assemble the phone and charge it, the battery recognition by android is reset and (for me) it worked totally fine again. This is also a workaround for the general Android WiFi-drainage bug.

1 Like

Never heard of this method before, but the officially confirmed method of resetting the battery is described in the #batteryguide.

Well i basically followed that guide but adapted it to the one described
when I had some problems occurring.

Hello again,

After I wrote the first entry to this forum and my battery was down at 57% after three hours without having performed any activities, I also checked the battery guide and waited until the battery was down to 1% and shutdown of my phone (It was around 2PM). At home I charged the phone again and wanted to check the battery consumption with the BetterBatteryStats App.

After I booted my phone again and hit the play store icon I wondered why the shop didn’t come up. And then I maybe became aware of what obviously happened: The Google Apps were gone! The OS update 18.04.1 rendered all google apps useless. They didn’t start anymore (Tried with maps and play store.
So I rebooted back to recovery and installed the OpenGapps pico ZIP file again for Android 6.

TO make it short: Everything is fine again. I guess that without google apps or services the OS was lacking a required service and either kept searching for it or connecting to it which caused the phone to become hot and the battery to loose capacity rapidly. I left home with 99% this morning and now it’s still at 59%. Its bad as well (I didn’t use it much: One 2 mins call and 20 minutes surfing the web) but I think its normal for the FP2.

Regards,

Michael

3 Likes

And I forgot: Thank you for all your comments and hints!

1 Like