English

Advice, please: Fairphone 2 won't boot and TWRP factory reset doesn't help

Hello Fairphoners,

I have had big problems after trying to apply the last update to Fairphone Open OS 18.10.

My phone will not boot up successfully but, instead, displays the TWRP recovery screen. I have tried to apply a factory reset several times using TWRP but the same thing happens.

The problem started when I attempted to install the new upgrade to android 18.10. I was using the previous version of Fairphone Open OS. Before applying the upgrade I made a system backup using TWRP. I was proud of myself for playing safe and not letting my excitement to see the new update overrule my caution - actually it turns out this was probably a big mistake :0(

After installing the upgrade opengapps was not installed so I followed the instructions posted on the forum by others with the same problem [Can't install open gapps on 18.10.0 (FP open)]. These suggested installing the TWRP app and using it to upgrade to the latest TWRP, then installing Opengapps. I did this but still had no success. Many of my apps were not functioning and my phone kept overheating. As I really needed to have access to my phone I decided to use my TWRP backup to return the phone to its previous state. When I attempted to use TWRP recovery to revert to my backup I recieved an error message that the recovery had been unsuccessful with error code 255. I tried again with the same result. When I attempted to restart the phone it could not get further than the TWRP recovery screen. It was at this point that I tried the factory reset with no success.

Please can anyone advise me on what to do next? I’ve run out of options and, of course, life is suddenly very complicated without a functioning phone.

backup in twrp - what version was twrp?

Hi LuBo, it was TWRP 3.1.1-0

and twrp version when you want to install the backup?

i understand a newer one?

then try to install the backup with the older twrp version?

Thanks for your help LuBo. TWRP 3.1.1-0 was the version I updated to. I don’t know the version I used to create the backup (25 something) but the backup file name is 2018-10-25–22-48-30_FP2-userdebug_6.0.1_FP2_fp2-sibon-18.04.1_r Does that tell you anything?

no, sorry, i started with the last version, but i read sometimes there are problems with different versions.

— was there a description for the failure 255? or did you search for it?

[quote]Ist bei Dir in TWRP unter “Mount” der Haken bei “Mount system partition read-only” gesetzt? Der muss weg.
Hast Du im recovery.log nachgeschaut an welcher Datei es liegt? Liegt bei mir auf oberster Ebene, kann auch in tmp liegen oder so.

Google liefert eine Fülle von Lösungsvorschlägen.

Wenn Du alles formatierst bzw. “wipest” (system, data, caches, nicht die SD-Karte mit dem Backup ! (https://www.android-hilfe.de/styles/default/xenforo/clear.png) ) sollte man ein Backup eigentlich einspielen können.)
(https://www.android-hilfe.de/forum/allgemeines-zum-custom-recovery.2269/twrp-error-255.806531.html)
[/quote]

it is german, but i think you have there some tips

Thank you so much LuBo for all your time and effort. I worked throught the tips (with thanks to google translate) but finally had to go with a fresh manual install of Open OS 18.04. Now I’m trying to work out why my fresh install of 18.04 with TWRP 3.0.2.0 won’t recognise the image of the TWRP update. Oh, will the fun never end?

Thanks again. I really appreciated your help.

If you don’t see the TWRP image in the file explorer in TWRP, there’s a button to switch TWRP from showing only ZIP files to showing only IMG files to select for installing.

Thanks AnotherElk, I’ve tried that. I used the file manager within TWRP to look in my SD card and, sure enough, there’s the apk I downloaded from the site. If I go back, click on image, as you suggested, then navigate to the same location nothing shows up. It’s very odd. I’ve tried using a different SD card and tried saving the file within internal memory, but with the same result each time.

Can you think of anything else I can try? Any other suggestions would be very welcome as I’d rather not go back to the standard os having been happily running on Fairphone Open for months.

Are you sure you’ve got an apk? If so, that’s your problem. You’ll need a .img file (should be here) if you’re installing from within TWRP.

1 Like

Thank you Johannes, yes that was one of my problems. When you pointed out my (embarassingly obvious) mistake I downloaded the correct image file (TWRP 3.2.3-0 - checked and double checked). TWRP recognised it, I installed it successfully - and yet, when I reboot after the installation and go into TWRP once more, the phone is still running 3.1.1-0 and can’t install the updated Opengapps. I encountered the same problem when trying to update TWRP using the TWRP app.

Thank you all: LuBo, AnotherElk and Johannes. Between you all you got me there. TWRP updated and Opengapps installed. Fantastic!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.