Adb Issue "List of devices attached ? no permissions" on Ubuntu 12.04LTS

Hi to you all,
I just got my FP1U and I’m playing around with adb. I’ve already enabled the debug usb but I got this error while trying to detect the device:

List of devices attached
???    no permissions

I looked around in the internet and I found this workaround

  1. adb kill-server
  2. sudo adb start-server
  3. adb devices

This worked for me, but what’s the proper solution?
Thanks in advance,


Acually, I think it is not a workaround but the solution. ADB might need root-priviledges to access the device on the hardware level. For me it is the same thing (Debian). On my wife’s laptop it works without root-priv. (openSUSE). I guess this is due to different rights settings.

I think the proper way to do this is to add a file /etc/udev/rules.d/51-android.rules. The way to do this is described here. The vendorID is 0bb4 (with productID 0c02) on my machine for the Fairphone.

Make sure your user is in the plugdev group and it should work as a user.


This worked liked a charm! The fun fact is that I already had a .rules file with those attributes (aren’t they the same for htc devices), but it was named 99-android.rules.
Now I wonder which should be the difference between these to files, but nevermind. Thanks for your reply!

Great to hear! Sometimes it can be very specific indeed. Never noticed the vendorID was the same as HTC, just did a lsusb on my system. Funny that it is the same as the Fairphone.