English

ADB in Linux can't find FP3

Hello! New to the forum.

I got my FP3 this weekend and I’ve sat every day since then trying to get TWRP and LineageOS on it but for some reason neither ADB or Fastboot can see the device.

Using lsusb I can see it and I can access the phone folders fine.
I’ve used what guides I could find, with the latest ones fiddling with getting it into 51-android.rules. But that didn’t change anything.

Anyone got a clue what I might have missed? I’ve also tried switching cables and trying on a Windows computer too but the phone doesn’t even show up there so I can add drivers.

Try to set “charge only” after plug in the cable and put on USB debugging in developing-settings .

2 Likes

Where did you get your adb version? With a simple “apt-get install adb” ? Try getting the one from android-developers website (SDK Platform Tools release notes  |  Android Developers).

Also, try to connect at least once with ADB through the Android OS to make it easier to get detected on fastboot mode.
The phone needs to be on “transfer files” mode.

And don’t forget to enable “OEM unlock” in developer settings. Happened to me once, it took me 20 minutes to realize that I forgot to do it…

1 Like

Thanks for the quick replies, guys! :slight_smile:
the phone is OEM unlocked and with debugging enabled. I’ve tried connecting in different ways but I’ll try different settings like you both suggested.

Where I got the ADB…? honestly it’s been so much back and forth so I don’t even remember anymore haha! but I probably went through the terminal. I’ll check that link either way. I know I have version 39 right now atleast and I think I checket that it was compatible with android 10, that is currently on my FP3.

I hadn’t noticed a way to get to the PC through the phone. Where can I find that?

This was it! I thought I had enabled USB debugging after following all those guides but clearly not. now it shows up and I can actually start working on this.

Again, thank you both! :sunny:

2 Likes

This along with the other USB debugging setting sorted everything out knock on wood Thanks!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.