Activating Google Advanced Protection Program leaves you without any option for login in again exluding Factory Reset

Hello Fairphone Community,
I’m using a Fairphone 5 and tried to activate Googles APP : Advanced Protection Program after that every device will be logged out. After that, I’m not able to login again on the Fairphone play services, leaves me behind without any Google Services.

After I enter my password I will be promoted with 2FA/Security Key, what isn’t shown properly on the screen and in an infinity loop. Terminate Google Play Services, deleting cache and rebooting down work. Only Factory Reset is possible but still leave me unable to use security keys.

Hope someone have an idea how to fix that

I haven’t looked into the security key issue on the FP5 (works on the FP4), but if you want a temporary workaround disabling the advanced protection program in your Google Account settings via a different device until the security key issue is resolved should do the trick.

Were you able to use your security key for other services on the device before enabling the APP (e.g. to log into this forum via a browser)? If so: Did you see a menu such as the one displayed in the screenshots below and were you able to select both variants? (These are from my FP4 running Android 12 based FPOS, so it may be a bit different on the FP5 and may well be a bug. I cannot verify this atm, as I do not have a FP5 at hand right now.)

First deactivating APP and waiting half an hour and rebooting the fairphone does work as workaround.

The screens you showed are the same on the fairphone 5 and I used them on several apps and websites. But after APP it won’t show up neither I remember it looks different at the Google login process for the play services. It’s just a black screen without another window just hold or plug in security key but it has a blue loading bar on top before you can scan it. After deactivating APP it goes smooth without any problems.

For Referene: I tried to log in to a Google Account on an FP5 with my YubiKey as a second factor but without the advanced protection program enabled earlier today, and everything worked fine (with both NFC and USB):

Have you checked wether Google requires your device to fulfill certain criteria to log into your account if you have the advanced protection program enabled (such as the bootloader being locked [this is speculation, not verified information])? After all they go as far as to restrict the sources from which you can install apps to Google-Play only (although already installed apps remain unaffected).

1 Like

Without the advanced program the login at Google with yubikey works fine. I didn’t changed anything on the bootloader. I think Fairphone should try to reproduce it. I wrote a support ticket and waiting for response. Im not so used to backup and restore in Android ebcusee I only used Apple devices before.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.