Accidently erased OS

Here’s what happened:

I was using Ubuntu Touch for the pass couple of months whithout any problems but unfortunately for a typical reason of app gap I was forced to go back to Android.

After reading online on how to, I pressed the volume + and power buttons together. The interface and menu were Ubuntu Touch’s recovery mode (and not the Android robot on his his back as I was expecting). The options were pretty similar so I decided to go forward, in the android options, and chose restore to factory.

Now here is what I get:

The phone doesn’t respond, if I try the poser button alone or even with the volume up and/or down, nothing comes up. I tried to removed the battery for half a hour but it didn’t do anything.

When I connect it via usb to my mac the black “fairphone powered by Android” appears with a vibration but stay there for a while. Then the screen goes back to black and the LED red light blinks, and after that nothing.

I tried to install the “flash-for-mac.command” while it was on the “fairphone powered by Android” display but it says that “no Fairphone 2 is connected”…

Seems like I screwed up badly, :pensive:

If you have any ideas I am willing to try anything, I’m running out of ideas…

Does the white Fairphone on black screen appear when you press power and volume down?
That would be fastboot mode and that’s where you should be able to communicate to the phone with your computer.

PS: Via fastboot you can then manually install the OS.

Here you’ll find the OS files. You’ll first have to install 1.13.0 and then upgrade to 18.02.0. But beware! If you have a relatively new phone or got a new screen recently than the screen won’t work once you are on 1.13.0. So be sure to flash the upgrade right after.

1 Like

Hi Paula thanks for responding so quickly,

Unfortunately no… any thing I try by pushing the physical buttons the phone does not respond.

The Fairphone display only appears when I connect to my mac via usb. It stays on for about 2-3 minutes then goes off. I thought too that this could be fastboot mode so I hurried to perform the “flash-for-mac.command” during that time, but the commuter don’t recognize it.

That would usually mean you have a deep-discharged battery, but you already basically tried a battery reset. Maybe try it again (full instruction in the #batteryguide). After you reinsert the battery after a while the LED should light red and then turn yellow. Wait until it’s green until you try anything else again.

1 Like

So I did the battery guide process and after 1 hour there is no change.

Phone won’t turn on nor react to volume buttons + power. When I plug it to my mac via usb the Fairphone display appears and then after awhile disappears and the LED blinks red continuously for awhile until it stops. It’s like a cycle, as long as I keep it plugged. Computer not recognizing phone when performing flash-from-mac.command on the fairphone display.

Well that means your battery still is deep discharged which in turn means some piece of hardware involved in the charging process is broken. So socket, plug, cable, bottom module, battery or (least likely) main module.

It is possible to do physical damage to the phone by switching OS? How I wish I would of known that before :sweat:

Thanks for helping out, is there any way I can know which piece is broken, like run a inspection or something?

No, that’s not likely. If a part of your phone is really damaged it’s probably coincidence.

What’s more likely is that it’s the cable or the plug that’s not working correctly any more and to find out which one it is simply try out different ones.

Thanks for being so helpful, I really appreciate it.

But I must admit that I have a doubt of such a coincidence of the plug breaking at the same time as I did the switch.

Afterall my phone does recognize that it is plug as it displays fairphone as soon as I plug it. I tired three different cables an got the same results.

I feel like it is a software problem and not a hardware one, but again, I’m here because I need help so I am not saying that you are wrong :slight_smile:

I should also had that when the fairphone display turns on, it stays on when I unplug it :face_with_raised_eyebrow::thinking:

1 Like

Do you happen to know any other FP2 users near you? You could borrow a charged battery and see if that makes a difference.

I’ll try to find someone or a battery to borrow. I’ll keep you updated!

I’m close to Lausanne in Switzerland if ever someone reads this :stuck_out_tongue:

Hi Paula,

So I did what you asked and found a second Fairphone battery that the owner showed me still works fine, just not as long of a battery life.

When I press the power button nothing happens, but as soon as I plug a usb cable the Fairphone displays comes up…

I’m quite confused now. If it is not the battery, how can I make it recongnizable for my computer? (or any other way of installing an OS)

It looks like there is something with your power button.
If you have a slim case, it could be worth to take of the case and switch the button of the power with the button of the camera.

Thanks Lidwien for your response.

The buttons do click well, but I did as you said and even tried pushing them with my fingernails without the case. I feel them click but nothing happens…

The only way I can get a response from the phone is when plugged to a usb cable (mac or power supply).

If only it could go into fastboot mode…

Sometimes sudo adb reboot bootloader works.

I do not have access to the terminal on the phone. I also do not have a linux computer. Can I operate this command from a Mac?

Yes. Just make sure you have adb and fastboot installed.

This command has to be typed from a computer anyway, with the phone plugged with a USB cable…

1 Like

Tried it in the terminal on Mac with phone plugged in. It says “command not found”