Accidentally deleted my operating system

My phone was freezing after the Uptdate 17.06.04. So i tried to fix it and failed. I hit the wrong buttom and deleted the complete operating System, data on the internal storage and wiped my total SD-Card.

I don’t want to recover my data. I just want to install an operating System that works. I prefer the Fairphone Open …

To the facts I can do and know certain:

  • I can enter the Team Win Recovery Mode and have acces to the “Menu” (Install to Reboot)

  • When i hit Reboot -> Power Off, it ans me " No OS installed! Are you sure you wish to power off?"

  • I have acces to the internal storage and the sd-card via my laptop (os = Linux mint).

  • I tried already to install the “” by using the Install button from the Team Win Recovery Mode. It doesn’t work and give me this:

“E: Zip signature verification failed: 1
Error flashing zip . /…
Updating partition details …
… done”

Can someone explain me how I install an operating System ?
Thanks i advance

I’m totally not an expert, but I think you have to skip the verification (and maybe use another package instead of the “switch”-one)

1 Like


I believe your file won’t work as you have no GMS version installed. I have not found the manual installation file for FP Open which I think you require. As a workaround I thought maybe install FP GMS OS first, then FP Open. But I don’t know how TWRP and FP GMS will work out together.

Anyway, for FP GMS OS you’ll find the complete download image in the support article below in section “Binary images (advanced users only)” and choose “FP2 - Binary images of Fairphone OS 17.6.4”.

To manually install FP Open OS try this page. Navigate down to “Method 2: Manual installation (using fastboot)” and download the manual update package.
As it’s size suggests (300MB), the resulting file “unzip” should contain the complete system and be flashable using twrp recovery.

Good luck.

After that you can twrp-flash the image “” from here to get to the latest version.


thanks for the answer. I forgot to mention I tried this manual installation but it seems to that I do not have the permission to do so. I got as answer:

“bash: ./ Permission denied”

ps: I’ll try now the workaround…

Is it executable? (Otherwise bash If that’s not the issue, what happens when you do fastboot devices?

Can’t you simply copy the files to your sd card and flash with twrp?

I can copy them but how do i flash with twrp?

The workaround didn’t work neither. I tried to install the binary version over the install menu of twrp. Even withaout the “check of verification” it doesnt work out

I don’t now if it’s exicutable.

with $ fast boot device and $ bash ./ the next line appears with < waiting for device >

Try to use sudo.
On many distros the fastboot command need to be run by su.

I had no permission with sudo neither.

Unfortunatly I face from now on more problems. I can’t acces twrp anymore and my computer does see the fp2 but can’t acces to it. It got me:
“Unable to open MTP device ‘[usb:001,055]’”

Does your computer find the device in fastboot mode?

(power off, then press vol down and power)

You can check that with:
sudo fastboot devices

1 Like

My FP2 also freezed after the OTA upgrade to 17.06.4. (It booted, but by the first touch on the screen it didn’t respont any more and the battery got drained very fast). I installed the Therefore I must make executable. In the zipfile it is not executable, but with linux mint it’s easy to change that. But that didn’t solve the problem. The FP2 no boots over and over again, always optimizing all the apps (107). Is there a way to reset to factory defaults before switching to fastboot mode and try again?

If you can get into recovery mode it should be possible, there’s an entry “wipe data/factory reset”.

I couldn’t perform the update using the Updater app (see here), but method 4 described on this support page (flashing the binary image from a computer) helped in my case - even without doing a factory reset beforehand.

Yea, with sudo found a device. but still i’ve no permission to exicute the ./ . Should I make this exicutable - that means bootfähig in german? I got an language barrier here.

bootable = bootfähig (Gerät/Partition)
executable = ausführbar (Datei)

1 Like

Good that the computer finds the device, then it should work to flash the OS.

Yes, make it executable.

sudo chmod +x

or instead you can run the script with
sudo bash
or with
sudo sh
depending on the shell you use.

I found a solution myself. First I started TWRP, made a factory reset and deletet the internal data. Then I installed The FP2 booted. After that I initialized the update and left the phone alone for about three hours (so long there was the message, that I have to wait). Finally the phone claimed the update finished. Now it boots and does’nt freeze.


Thanks a lot.

it worked out and now I can start to use my phone again :slight_smile:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.