Accidental swipe input detection from touchscreen keyboard when typing, fp4

Hi,
When using Gboard keyboard, with Swipe enabled, it quite regularly- maybe every few minutes of keyboard use, detects a tap as a swipe. So I get a space in the middle of a word, then say CCC rather than c (as CCC is an acronym I use), then space and word continues. It’s pretty annoying.

If I turn off swipe input it works perfectly - but I like swipe for if I have to type long words quickly or type one handed!

Any suggestions, is there a way to make swipe input less sensitive? Am I typing ‘wrong’ like too low/fast and others with it on don’t see this? I typed with both fine on my FPs 2 and 3
Ta