Accidental partition on FP1U - but not with the storage upgrader

Hi there,

I recived my FP1U last week and I think I already made a terrible mistake.
I installd this app:

to make a partition for the internal storage and the telephon storage - this has worked very well on my wife’s FP 1st. edition.
So I didn´t notice that there was a different storage layout on the new FP.
Now I´ve got an 5GB internal storage and you can imagine I´m pretty angry with myself…
Is there a way to revert this mistake?
The installation of google play store and the other apps by using the widget also doesn´t work

First make a backup.
Then try to run the storage upgrader.
You need FP1 Storage Upgrader*
Instructions and this file can be found on Fairphone Os (multiple versions)

1 Like

Thank you for your quick answer.
Sadly your suggestion doesn´t fix the problem, I´ve tried it out a few minutes ago…
Any other ideas?


You may need to manually reflash the original recovery image to your FP.

You can try installing the v1.6 update via the flash install method

If this doesn’t work then you will need to try the SP Flash tool - this is more advanced, so if you’re uncomfortable doing it then I suggest you contact Fairphone Support directly for further assistance. All details are in this article and you want the section at the bottle for a totally bricked phone. The FP binary files you’ll need for this method are these ones (Note these are for the FP1U i.e. Second Batch phones only)

Thank you chris,
my FP runs alredy with the 1.6 version, by use of the manually reflash method.
But this doesn´t solve the major problem.
I think I need to contact the FP support directly because I´m not that developer guy, I´m more a user ; )

Thank you anyway for your support, this is a very nice forum.

Hi @Christian,
I’m sort of having the same problem (I think):
Is yours solved already?

Re Hi,
I get contact to Rick Form the official FP support and he sent me a Kind of
tutorial to get it fixed. By help of an professional I got my Phone
completly fixed, means as it was in the beginning. Im gonna reply bis mail
Tod you.

1 Like

Thanks @Christian!
Your mail with the tutorial (from Fairphone’s own Rick) got the job done!
(Flashing the EBR1 from the FUSE binairies to my FP1).

Could you place the tutorial here?
Then other people could use it also when they have the same problem.

here is Rick’s tutorial (with a few notes of my own; also posted on XDA Developers site):

[QUOTE]You can only fix this by flashing your phone:
For GURU’s only! ([I]flashing with ADB[/I]). The alternative is to use the windows flasher tool.

  1. Download the original image binaries from Fairphone’s site:

  2. unzip the file
    ([I]I chose to unzip to location D:/FP1U.
    after that i moved all content from the directory which contained EBR1, to D:/FP1U.[/I])

  3. enable usb debugging ([I]on your phone: [B]Settings[/B], [B]Developer options[/B], turn [B]USB debugging [/B]on[/I])

  4. push EBR1 on the phone: ([I]Open (if you’re using Windows) the Command Prompt[/I])
    adb push FP1U/EBR1 /mnt/sdcard/

([I]For instructions on how to use ADB, search with Google / XDA Developers’ site[/I])

  1. become root:
    adb shell
    ([I]after that I also became super user (command [/I]su[I]), but maybe that’s not necessary; Rick didn’t mention it. [/I]:))

  2. override the partition information:
    dd if=/mnt/sdcard/EBR1 of=/dev/ebr1

  3. reboot into recovery:
    reboot recovery

  4. choose to wipe data and cache
    ([I]after that, choose reboot[/I])[/QUOTE]

Hi! I have the same problem, though I don’t know what it means to

Flashing the EBR1 from the FUSE binairies to my FP1

Can someone pls explain this, what do I do?
I just tried several times to partition, it just doesn’t work.
grateful for help thnks!