Accessing internal memory on a dead FP2

Hi, my FP2 died quite recently. (It’s as far as i know not a battery issue - I read those threads)
Is there any way to access the internal memory? I’d like to recover images and some SMS messages from there.

1 Like

is your phone completely broken or is there a reaction if you try to turn on your phone?

If you can access the fastboot mode (Volume down + Power), then you can follow this guide:

The only reaction i get is if i remove the battery and insert the power cable the LED-light turns red for a second. Then nothing. So I can’t access the OS or switch anything on.

So I think i need to access the memory by physically removing it and inserting it in something else. If that’s even possible?

Thanks a lot,

Did you already try the workaround in this topic?

Yeah I have several cables and they all worked before.

But I can’t find any guides on accessing the physical memory.


This is a hardware solution, then, and I guess a hard path. You should get advise from an electronic engineer. Also note that dissasembling the “core module” (where the storage memory chip is placed) will void your warranty for sure.

Edit: If you take the FP2 battery, keep pressed the Volume down and then connect the USB cable plugged to your computer, you should access the fastboot mode. I couldn’t load the recovery without battery, but maybe you can use the fastboot mode for something else? I don’t know if you can read/backup a partition from there in someway.
(Please note: it is really easy to erase a partition data in fastboot mode! Be careful)

Edit2: For some devices (not all, I think), there’s a command for dumping images from fastboot: fastboot oem partition dump boot.img (you’ll probably want userdata.img). I’ve not tried it with the FP2 yet, but with a dump of that class, I could easily teach you how to extract their contents.

Did you check if the battery sits tights so it can deliver power?

Did you try to disassemble and reassemble the phone?
Maybe you have a loose connection somewhere that could be fixed this way.

Hey, remember that FP2 is modular :slight_smile:
If for sure you cannot easily extract the memory chip itself, you can still try to remove your core module and mount it in a working FP2 to get your data.

But I think you have a battery or charging issue, so it could be a better and simpler start to try inserting a charged battery from another phone.

Yeah it’s none of the above that was the first thing i tried. Any clue on how to access the physical memory? Or get a reply from support so I can use the warranty to get a new phone?

Yeah, and if I remove the battery and insert the power cable I should still be able to charge the phone right?
If not, it might be a fried battery.

So I tried the cable again. (It’s been about 3 weeks since the phone died)

This time there was a blinking red light for about 3 minutes. Then nothing and no response.
Removing the cable and inserting it again does nothing like before.

Red blinking is a sign for a deep discharged battery.
You may try to rest the battery (maybe in 2 or 3 attempts), as this could bring the battery back to live. See #batteryguide on how to do that. Follow it precisely (when starting to charge, don’t turn on the phone, Just let it sit).

I have also read from users where the bottom module had a loose connection. Disassembling and reassembling the module helped them to be able to charge again.
Since the battery seems deep discharged, it may be so that the bottom module doesn’t deliver the power to the battery.


do you know someone with a Fairphone 2? I think you should try a different battery.

Maybe there is a community near you where you can borrow a battery to check you phone:

1 Like

Hi, if that had been the case it should be possible to boot the phone without the battery. That doesn’t work, so I’m guessing something else is wrong. Or did I missunderstand the boot procedure?

Thanks for the suggestions

1 Like

Might be worth checking out, thanks. Although I think the phone should be able to boot with just power cable if I remove the battery, right?

Thanks for the help,

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.