A9 GPS Problem (GPS Logger/Hardware/Services?)

Short backstory: my FP2 was getting more unusable by the day (random reboots up to 20x a day, freezes, glitches - I thought the GPU was dying). With the latest Upgrade to Android 9 (FP Open OS + Open GApps) it runs mush smoother now. Almost no reboots. Every now and then a single app crashes, but that’s ok.

My problem now is the GPS function/hardware. I’m using SatStat, OSMand+ and GPS Logger (https://gpslogger.app/). With Android 5-7 I always was quite fond of the accuracy and battery performance of the FP2. I usually have location disabled. When I go for a bikeride, I usually activate location, start SatStat to get a fix (this still works pretty good) and start GPS Logger afterwards. When I’m lost, I open up OSMand+

On my last tour, I wanted to have a look at my position in OSMand+ and noticed that the back of the FP2 was very hot. The location indicator of OSMand+ also somewhere behind my real position, although blue in color, saying it had a fix. After riding on, the indicator stayed at the same place, so something was wrong. I also noticed that the total distance in GPS Logger was way too low. SatStat didn’t show any sign of a working location service. At home I was curious about the GPX file and saw that after around 35min the track just ended. I tested the GPS Logger on a car and train ride with the same result: FP2 gets hot, logging stops after between 35-40 minutes, every time.

At first, I thought UnifiedNlp could be the cause of the problem. I never used it and now it was preinstalled with FPOOS. Indeed, I got the error “UnifiedNlp has no last known location” so I tried The LocalGsmNlp and Mozilla Backend which just caused my FP2 to freeze when opening up GPS Logger or SatStat so I deactivated UnifiedNlp but my main problem with the loss of a GPS signal after 35-40mins persists.

When I have GPS Logger turned off and only look for my position in OSMand+, I get a fix real quick and have no problems even after hours. I imported my performance settings and I couldn’t find any related bugs on Github so I’m not sure if it is a GPS Logger problem, a problem with some background services or with my hardware.

It’s a pretty long post so thanks if you read this far :smiley:
Does anybody has a common issue or a clue what the cause of this problem might be? I’d love to be able to track my rides and hikes again.

How hot is the phone when you notice this? If the phone is too hot (CPU reaching 85-90°C), it might have some security process that cuts any high-demanding task, such as GPS. I have noticed this myself when doing high-demanding operations on the phone, when reaching around 85°C, it slows down heavily.
You can measure the temperature of the CPU and battery with e.g “CPU info” from F-Droid.


Thanks for your input, Alex!
I’ll try it with CPU info next time. I don’t think it reached 85 °C though, I could still touch the back without issues.

1 Like

When the CPU is at 85°C, the heat has to go through the plastic case of the core-module + the back cover, so the temperature is much lower at the end, and it should only be very very hot, but not burning hot.

That depends where the heat comes from and goes to, either from the SoC itself or the hot sun…

1 Like

Tried to log my recent tour with OSMAnd+ instead of the GPS Logger App the other day. Set the interval to 2 seconds and it worked perfectly! Battery went down from 95% to 85% in about 3,5h (taken some Photos, looked at the map a few times).
I’m happy and satisfied with the performance of OSMAnd+

Still wondering, whether some settings of GPS Logger triggered a malfunction of the GPS feature of my FP2 or there’s a bug. I had the same settings as before my Android Upgrade and I think there was no new GPS Logger released since.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.